MR-U3-6G Docking station is not recognized by Ubuntu

    MR-U3-6G Docking station is not recognized by Ubuntu

    MR-U3-6G Docking station is not recognized by Ubuntu but I just noticed Windows 10 doesn't seem to have a problem with it.

    According to the datasheet it should work fine on Windows Vista/7/8/8.1, Mac OS 10.3 and above, Linux

    lsusb doesn't show any drive I have tried - I have tried to connect the same harddisks with a Logilink docking station that works without any problem. I even returned one MR-U3-6G thinking it was a hardware problem, now the next one I received from the seller has exactly the same issue (the reason I gave it a try on windows this time). I never expected to have Linux related hardware issue in 2017 for a standard product like this... So I am pretty disappointed in Fantec.
    Tried it on two different devices: Desktop running Ubuntu 16.04 and laptop running 17.04 both failed.

    [Edit] BTW - devices I am using are USB 2.0 devices.

    Lusb doesn't show the device. Any advise appreciated.

    Post was edited 1 time, last by “T_b_F” ().


    we didn't get any other informations about such problems and as it was tested with Linux it was okay.

    We will double check this issue and get in contact with the manufacturer but please understand that this things will take a while so i can't tell you when we got an information about it.

    Best regards,
    OK - thanks
    Got some more details for you.

    The device does work on Linux using USB 3.0 connection. I have tried it on a PC that has both USB 2.0 ports and USB 3.0 ports. The docking station is recognized connecting it to USB 3.0 ports and not by using USB 2.0 ports. From what I have understood USB 3.0 devices should be backwards compatible so it is still something to investigate. I was totally in the impression I could buy any USB 3.0 device and use it on my laptop without upgrading to USB 3.0

    Haven't tried connecting it to a Windows PC with USB 2.0 so can't tell you if the same applies to Windows

    we tested it with Fedora Live and got no problems with USB 2.0 and 3.0. Seems like this is a problem with your computer or your Distribution but we will keep an eye on this case. :thumbup:

    Also on Windows it's working as suggested with USB 2.0 and 3.0.

    Best regards,