MR-35DRN - Zugriff verweigert auf Unterverzeichnis nach Stromausfall

    MR-35DRN - Zugriff verweigert auf Unterverzeichnis nach Stromausfall

    Hallo,

    nach einem Stromausfall kann man Dateien in einem Unterordner eines SMB-Shares nicht mehr öffnen: "Zugriff verweigert". Zugang erfolgt mit dem "admin"-Login.

    Windows meint dazu, dieser Unterordner und alle Dateien und Unterordner darin seien im "Besitz" eines "unbekannten Users" mit einer numerischen UUID. Alle andern User hätten dort - leider - keinerlei Lese- oder Öffnen-Rechte.
    Besitz übernehmen oder an den Rechten sonst was ändern klappt auch als Administrator nicht.

    FTP ist aktiv, aber zeigt gleiche Situation: auf diesen Unterordner & Inhalt "Zugriff verweigert".

    Firmware ist mit "2.6.7-rn" vermutlich original, jedenfalls sind die Ports 21, 80, 111, 139, 445, 515, 611, 666, 2049, 3625 offen, also FTP, HTTP, SUNRPC(?),SMB,LPR,npmp-gui(?),Remote Management(??),NFS und 1 unbekannter Dienst.
    Leider weder Telnet noch SSH...

    Hat jemand Ideen was man tun könnte, um die Dateirechte zu korrigieren?
    Vielen Dank,
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett
    Hallo,

    verrätst Du uns auch, um welches NAS es geht oder sollen wir eine Ratestunde einlegen? :D

    edit: laut Tag spekuliere ich mal, dass es um ein MR35DRN geht, korrekt? Bitte künftig direkt in der Überschrift angeben, damit wir nicht erst suchen müssen. Ich habe mal die Themenüberschrift entsprechend angepasst.

    Normalerweise ändern sich die Zugriffsberechtigungen nicht durch einen Stromausfall, sondern Dateien werden beschädigt, sofern während des Stromausfalls Schreibzugriff auf den Platten herrschte. Im schlimmsten Fall zerschießt es sogar die Raid Infos und den Partition Table. Also unbedingt an Backups denken.

    Lass mal Telnet und SSH außen vor und überprüfe als erstes mal im Share Management, auf der Weboberfläche des NAS sämtliche Einstellungen. :thumbup: Richte auch mal einen neuen Nutzer ein und gib bei diesem die besagten Ordner frei. Wenn auch das nicht hilft, wäre interessant zu wissen, wie die Platten im NAS eingerichtet sind. Danach richtet sich dann nämlich, ob es Sinn macht, eine der Platten mal losgelöst vom NAS, direkt an den Rechner anzuschließen und die Dateien zu prüfen, ob hier wirklich ein Rechteproblem vorliegt oder die Dateien beschädigt wurden.

    Normalerweise werden die Dateizugriffsrechte nämlich nur von Windows selbst auf stationären Datenträgern verändert, so denn man dies manuell veranlasst. Auf NAS Laufwerken kann Windows nicht so ohne weiteres die Zugriffsrechte verändern, es sei denn Windows wurde von Dir oder einem Admin entsprechend modifiziert.

    Hilft das alles nichts, würde ich das NAS mal komplett neu einrichten. Dann ist da irgendwas anderes schief gelaufen und die Dateien und dessen Zugriffe wurden auf irgendeine Weise, die wir hier so nicht nachvollziehen können, verändert.

    Was heißt eigentlich, "vermutlich die Original Firmware". Du hattest von mir die modifizierte FW erhalten - Du musst doch wissen, welche FW Du installiert hast? 8o

    Grüße

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „paddylein“ ()

    Moin,

    ich rate mal anhand der älteren Beiträge: MR-35DRN :D

    Allerdings sieht es dann auch schon eher nicht mehr so gut aus...vielleicht auch "einfach" der Windows Benutzer gesperrt? Den Zugriff mal mit einem anderen Rechner oder Profil ausprobieren für den Anfang.

    Vielleicht kann paddy an dieser Stelle auch nochmal einspringen, der ist ein Profi im Netzwerk! :thumbsup:

    Gruß,
    Lars
    Hallo,

    ja sorry wegen Modellname nur im Tag, da hab ich zu sehr um die Ecke gedacht.

    Beim Stromausfall damals kann natürlich der ebenfalls betroffene Windows-PC gerade beim Schreiben aufs NAS unterbrochen worden sein, sodaß der Fehler vielleicht deswegen entstanden ist.
    Seltsamerweise eben keinerlei Schaden am (vermutlichen) RAID1 oder Partitionstabelle, sondern nur an den Rechten unterhalb \public\Mama.

    Da weder Telnet noch SSH offen sind, kann ich das in der Tat (un)getrost ignorieren.

    Danke für den Tipp mit Share Management, das erhellt die Situation etwas:
    Der Share heißt "public", entsprechend /mnt/md1/public.
    NFS ist anscheinend aktiviert, aber nicht konfiguriert,
    Windows/FTP sagt [x] grant access to all, Access granted [admin (writable)] Access denied ist leer.

    Einen neuen User test, Pw. test angelegt und für public auch unter Access granted hinzugefügt. Versucht mit explizit dessen Login zuzugreifen:
    net use y: /delete
    net use y: \\fantec\public /user:test test
    klappt soweit, aber:
    Der Zugriff auf alles unter y:\Mama\ wird unverändert verweigert.

    Alle Ordner und Dateien (viele viele Stichproben...) unter public haben unter Windows in ihren Dateieigenschaften->Sicherheit folgende Liste:
    Gruppen- oder Benutzernamen:
    Jeder
    nobody (Unix Group \nobody)
    Unbekanntes Konto (S-1-5-21-3435980906-19...)
    und keiner davon hat in der Liste "Berechtigungen" darunter irgendwelche Haken, nicht bei Zulassen und auch nicht bei Verweigern, außer das unbekannte Konto mit "Spezielle Berechtigungen [x] Zulassen".
    In Erweitert sieht man dann auch wieder bei allen geprüften Objekten:

    Besitzer: Unbekanntes Konto (S-1-5-21-3435980906-19...)
    Berechtigungseinträge:
    ...
    Zulassen
    Unbekanntes Konto (S-1-5-21-3435980906-19...)
    Vollzugriff
    Keine
    Nur diesen Ordner
    Zulassen
    nobody (Unix Group \nobody)
    Keine
    Keine
    Nur diesen Ordner
    Zulassen
    Jeder
    Keine
    Keine
    Nur diesen Ordner

    Obwohl da scheinbar kein Unterschied existiert, ist public\Mama leider doch ein Spezialfall, denn trotz dieser "Einschränkungen" können alle Dateien und Ordner geöffnet und auch geschrieben werden, außer denen unter public\Mama. Und dies "Unbekannte Konto" ist auch seltsam.

    Zugriff hatte ich getestet vor Ort sowie hier am eigenen PC, mit unterschiedlichen lokalen Usern, und identischem Effekten. Soviel zum gesperrten Windowsuser, nehme ich an.

    Ich sagte vermutlich Originalfirmware, da es sich um die Kiste einer Bekannten handelt, wo ich um Hilfe gebeten nicht Nein sagen konnte. Sie ist eher wenig technikaffin, also hat das wohl Originalzustand; aber der ihr das Ding hingestellt hat kann natürlich auch die Finger drin gehabt haben.
    Danke trotzdem nochmal für die alternative Firmware, die ich aber erst später evtl. versuchen will, es ist ja nicht mein Gerät...

    Falls man die Situation so nicht ändern kann, wird wohl vor neuer Firmware erstmal der Versuch anstehen, die Platten auszubauen und anderswo (Linux) anzuschließen.
    Da das wohl ein RAID1 ist: reicht da nicht eine Platte für den Versuch? Gibts damit schon Erfahrungen?
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett
    Hallo,

    weiah, was ein Chaos 8o . Ist also nicht Dein NAS und die alternative FW hat hiermit nichts zutun - gut.

    Das heißt also, Du weißt selbst nur durch Hörensagen, dass der Fehler angeblich erst seit einem Stromausfall besteht? 8o
    Könnte es nicht vielleicht sein, dass diese ominösen Rechte bei der Bekannten und deren Windows Rechner eingeräumt und mit PW belegt wurden, eben weil er oder sie nicht ganz so technikaffin ist? Verstehe mich nicht falsch, mir geht es nicht ausschließlich darum, den Fehler bei einer Person zu finden. Fakt ist aber, dass im NAS offensichtlich alles korrekt läuft aber unter Windows irgendwas mächtig schief gelaufen sein muss. Da kannst Du auf der NAS Oberfläche und mit Telnet und Co. versuchen, was Du willst. So lange Windows da irgendwo seine Finger mit im Spiel hat und keiner so wirklich weiß, was da passiert ist, ist es nahezu unmöglich, das Problem in den Griff zu kriegen.

    Wenn überhaupt, würde ich das noch mal in der Netzwerkumgebung versuchen, wo das NAS war und dann an den/die Rechner gehen und dort versuchen die Besitzrechte zu übernehmen, bzw. dieses ominöse Benutzerkonto zu entfernen und die Rechte für "JEDEN" einzuräumen. Im Admin Modus unter Windows sollte das eigentlich gehen.

    Wie gesagt, lass die Finger von Telnet und SSH - zumindest, wenn Du uns hier offiziell um Rat bittest. Warum immer alle gleich zu Telnet und Co. greifen müssen, ohne erst mal das banalste, die Weboberfläche selbst zu bemühen, wird mir immer ein Rätsel bleiben. :D

    "Vermutlich" ist immer eine ganz bescheiden Aussage, bei einer Fehleranalyse. Welcher Raid Verbund initialisiert ist, darüber sollte ebenfalls die Weboberfläche Auskunft geben. Viele Möglichkeiten gibt es da ja nicht.

    Wie man auf eine Raid 1 Platte außerhalb des NAS Zugriff erlangt, dazu einfach mal das entsprechende Tutorial im Erste Hilfe Bereich anwenden :thumbup: . Da existiert ausschließlich für dieses NAS ein eigenes Tutorial!

    Ich würde da auch gar nicht mehr lange rum basteln. Platte(n) sichern, wenn kein Backup existiert und neu aufsetzen. Da niemand wirklich weiß, was da letztlich schief gelaufen ist, macht es keinen Sinn, herumzubasteln und potenzielle Fehler zu verschleppen.

    Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „paddylein“ ()

    Hallo,

    gerade schon selbst über "How-To: Datenrettung von einer MR-35DRN RAID1 Festplatte" gestolpert - ja, wer lesen kann ist klar im Vorteil. Das erledigt dann also schonmal meine letzte Frage (und Deinen letzten Tipp, Danke), nehme ich an.

    Mit Hörensagen hast Du ganz recht - aber was einem nicht gehört, zu dessen Schicksal gibts eben meist nur Hörensagen, auch wenn der Erzähler Stein&Bein schwört...

    Wie gesagt, Besitz übernehmen oder an den Rechten sonst was ändern klappt auch als Administrator nicht. Hatte ich schon als allererstes noch vor Ort versucht, bevor ich sicherte was ging, die NAS abbaute & mitnahm.

    Angeblich *kann* die Original-FW ja weder Telnet noch SSH, da kann ich mich also gut zurückhalten...

    Wenn ich was nicht belegen kann behaupte ich's lieber nicht sondern vermute halt. "Educated guess", sozusagen.

    RAID-Format ist witzig:
    Die Disk utility nennt für beide Platten Format ext2,
    in RAID Setting steht dagegen Raid level: RAID 1 File system: EXT3.
    (Wat denn nu? Ok, ich weiß, Ext3 ist Ext2 plus Journal, ist aber trotzdem ein ganz klein wenig irritierend...)

    Backup? Ist das n neues Kuchenrezept? So eine ähnliche Antwort würde mir die Besitzerin vermutlich geben wenn ich sie *danach* frage...

    Danke für die Hilfe soweit, ich geh denn mal Tutorial lesen...
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett
    Hallo,

    uninett schrieb:

    Mit Hörensagen hast Du ganz recht - aber was einem nicht gehört, zu dessen Schicksal gibts eben meist nur Hörensagen, auch wenn der Erzähler Stein&Bein schwört...


    Naja ich halte mich da für meinen Teil an die Fakten, somit den aktuellen Stand. Die "Geschichten" drum herum, so denn sie dann auch noch von einem Laien stammen, interessieren mich nur marginal. Sie leiten oft in die Irre, mehr nicht. :P Und das ist nicht mal böse oder abfällig gemeint, sondern einfach nur ein weiterer Fakt. In 90% aller Fälle liegt es eben nicht an der Vermutung des Laien sondern hat ganz andere Gründe. Es sei denn natürlich, die Gründe sind plausibel replizierbar, dann interessiert mich natürlich auch das.

    uninett schrieb:

    Wie gesagt, Besitz übernehmen oder an den Rechten sonst was ändern klappt auch als Administrator nicht.


    Was heißt auch - wenn überhaupt, geht das nur als Admin und auch am besten nur im abgesicherten Modus.

    uninett schrieb:

    Angeblich *kann* die Original-FW ja weder Telnet noch SSH, da kann ich mich also gut zurückhalten...


    Ob sie es kann oder nicht - diese Wege sind offiziell nicht freigegeben, PUNKT! :thumbup: Wer sie dennoch nutzt, weiß entweder was er tut oder ist selber Schuld, wenn was schief geht :thumbsup: .

    uninett schrieb:

    Backup? Ist das n neues Kuchenrezept? So eine ähnliche Antwort würde mir die Besitzerin vermutlich geben wenn ich sie *danach* frage...


    Okay... ja, was soll ich dazu sagen? Ich sage mal so: Um in Deutschland eine Waffe besitzen zu dürfen, muss man einen Waffenschein erwerben. Um ein KFZ fahren zu dürfen, muss man eine Fahrerlaubnis erwerben - EDV Technik, egal wie komplex und Datengefährlich bei falschem Umgang, kann von "jedermann" erworben und in Verwendung genommen werden... Und dank YouTube DIY Videos wird dann auch jeder halbwissende zum scheinbaren Profi :thumbup: . Kein Wunder, warum die Versicherungsstatistiken, bezüglich Unfälle und Schadensmeldungen in die Höhe schnellen. Dank YouTube wird die gemeine Hausfrau/der Hausmann mal schnell zum Starkstrom Elektriker oder Gas/Wasser Installateur - bis - ja, bis die Hütte abfackelt oder unter Wasser steht...

    So, genug OT Geblubbber.

    Wie gesagt, wenn Du keine Optionen findest, die Rechte unter Windows zurück zu erwerben (Hier ruhig auch mal in der Knowledge Base von MS reingucken, denn diese Probleme gibt es, seit es Windows mit Benutzerverwaltung gibt - also schon ziemlich lange :D ) und der Grund für diesen Fehler schleierhaft bleibt, ist das Tutorial noch die einzige Möglichkeit, zumindest speziell die besagten Dateien zurückzuerhalten. Danach ist so oder so NAS neu aufsetzen angesagt, damit keine potenziellen Fehler weiter getragen werden.

    Grüße
    Hallo,

    mal ganz kurz ein Beispiel genannt, wie genau ein solches Problem entstehen kann und ich hier auch schon zu Hauf bei uns im Projekt auflaufen hatte.

    - Kunde kauft NAS und richtet Benutzer mit Passwort ein
    - Kunde richtet danach ein festes Netzlaufwerk unter Windows ein, sodass dem NAS Share ein fester Laufwerksbuchstabe zugeordnet ist.
    - Kunde hat gehört, dass es sinnig ist, seine persönlichen Daten durch ein Passwort zu sichern. Logisch - durch die Einrichtung eines Netzlaufwerks, mit Hinterlegung der Zugangsdaten kann natürlich wieder jeder an diesem laufenden Rechner an die Daten ran.
    - Kunde geht also Herr und verwendet die Windows Login Funktion, womit sein Teil von Windows nun nur noch er "betreten" und auch nur er seine Daten sehen kann.
    - Kunde hat gehört, dass da aber noch mehr Sicherheit geht. Also geht Kunde her und fummelt richtig derbe in den Sicherheitseinstellungen rum und aktiviert z.B. zusätzliche Verschlüsselungen, die Einbindung sämtlicher am PC angeschlossener Laufwerke, wie z.B. auch das NAS mit seinem Netzlaufwerk, vergibt Nutzerrechte für einzelne Laufwerke etc.! Warum? Weil jeder Windows Nutzer von hause aus bei Inbetriebnahme einfach mal in den Stand eines Administrators erhoben wird, denn schon bei einer frischen Windows Installation ist der Erstnutzer immer auch gleich Admin und kann somit alles nach gut dünken einstellen!

    Dann will der Kunde irgendwann seinen Rechner erneuern, neu aufsetzen oder in sonst irgendeiner Form verändern und wundert sich dann, warum er plötzlich nirgends mehr Zugriffsrechte besitzt.
    Oder aber wenn es sich um die Einbindung eines Public Ordners handelt, wundert er sich, warum plötzlich nur noch er Zugriff hat und niemand mehr sonst im Netzwerk. Tja, wenn man das NAS mittels Windows Bordmitteln aushebelt/umgeht, passiert sowas nun mal. ;)

    Und dann heißt es einfach nur platt "verstehe ich nicht, hab alles so gemacht, wie bisher, habe nichts verändert und es klappt nicht mehr, aber gestern war das NAS mal kurz Stromlos, das wird es gewesen sein..." :thumbsup: .

    ​Spaß beiseite - ich habe in 20 Jahren beruflich geschuldeter Administrativer Tätigkeiten noch NIE, wirklich noch nie den Fall gehabt, dass ein Stromausfall für eine plötzliche Veränderung der Zugriffsrechte unter Windows verantwortlich gewesen sein soll, erst recht nicht für nur bestimmte Ordner und Dateien.

    Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „paddylein“ ()

    Hallo,

    definitiv OT: wer einen Führerschein hat, weiß nicht wie die Vergaserinnenbeleuchtung zu reparieren geht und will das auch gar net wissen. Trotzdem wird bei seltsamen Geräuschen bei Bodennebel in Rechtskurven unterhalb von 30km/h doch gern erstmal der Schrauber in der Verwandtschaft "gefragt"...
    Genug davon.

    Lehrvideos mag ich net, die sind so sequentiell und haben unpraktischerweise meist kein Inhaltsverzeichnis.

    Ich glaube auch es ist mittlerweile fruchtlos, bei der Besitzerin nach Ursachen zu forschen; allein, dass nur ein Unterordner betroffen ist, ist doch sehr merkwürdig.

    Das Tutorial gibt den Weg vor, 1 der 2 Platten zu mounten und auszulesen; allerdings ist das RAID danach "degraded". Kann man das nicht evtl. vermeiden? Ich will ja an diesen Platten vor der Datenrettung gerade nichts verändern, was m.W. ein "Start RAID Array" mit nur 1 Platte aber machen würde.

    Nach mehreren Quellen wie ubuntu - How to mount/recover data on a disk that was part of a mdadm raid 1 on another machine? - Unix & Linux Stack Exchange könne man aber auch mit 1 Platte ohne "degraded"-Resultat Erfolg haben, was aber im Detail von der verwendeten mdraid-Version auf der NAS (0.9 bis 1.2) abhängt (s.a. RAID superblock formats - Linux Raid Wiki).

    Nun sind aber ja beide Platten zur Hand, also ginge wohl auch das komplette RAID1 an einem Linux-PC zu mounten ohne es zu "zerstören", nicht?

    Aber übers Knie brechen muss ich das jedenfalls nicht.
    Schönen Feiertag erstmal.
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett
    Hallo,

    uninett schrieb:

    wer einen Führerschein hat, weiß nicht wie die Vergaserinnenbeleuchtung zu reparieren geht und will das auch gar net wissen.


    8o :thumbsup:

    ​Mein Beispiel ging im Vergleich ja auch eher in die Richtung, dass man eine Fahrerlaubnis (Dein Begriff ist mir politisch zu kritisch :D ) in unserem Land benötigt, um überhaupt ein Fahrzeug bedienen zu dürfen, nicht um es zu reparieren. ;)

    ​Du kannst auch eine Platte nehmen, Du musst nicht beide Raid Platten nehmen. Und wenn Du ganz sicher gehen willst, klonst Du die eine auch noch, dann bist Du ganz auf der sicheren Seite :thumbup: .

    Grüße
    Hallo,

    nun gut, Fahrerlaubnis *ist* neutraler - ich meinte halt den "Luxus der Ignoranz" den man sich glaubt leisten zu können, so'n NAS zu kaufen & betreiben ohne alle nötigen Feinheiten zu beherrschen.

    Die Absicht beim Anschluß *beider* Platten wäre das vermeiden des "degraded"-Zustands.
    Und klonen einer Platte wäre in der Tat eine Alternative, nur hab ich persönlich noch keine 1TB-Laufwerke so übrig rumliegen. Aber überlegenswert.
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett
    Hallo,

    uninett schrieb:

    Die Absicht beim Anschluß *beider* Platten wäre das vermeiden des "degraded"-Zustands.
    Und klonen einer Platte wäre in der Tat eine Alternative, nur hab ich persönlich noch keine 1TB-Laufwerke so übrig rumliegen. Aber überlegenswert.


    Du kannst ja schauen, ob Du es ohne degraden schaffst, auch wenn ich nicht nachvollziehen kann, was am degraden so schlimm sein soll. Diesen Verbund solltest Du so sowieso nicht mehr zusammenführen.
    Das degraden bewirkt letztlich ja erst mal nur, dass die beiden Platten so nicht mehr ohne weiteres zu einem Raid zusammengefügt werden können.

    Für was auch immer Du Dich entscheidest - Du solltest Dich dann doch mal langsam entscheiden, sonst wird das Problem wohl niemals gelöst. :D
    Ein Restrisiko wird bei allen Optionen bleiben.

    Wenn Du Dir das Recovery nicht zutraust, kann ich Dir nur das Angebot machen, uns (siehe Signatur und "Über mich" Seite) das komplette NAS, nebst beider Platten zuzusenden. Wir/ich haben da aus beruflichen Gründen noch mal ein paar mehr Möglichkeiten und Optionen - dann übernehmen wir das Recovery gegen eine kleine Unkostenpauschale, nebst Spende für unser Projekt.

    ​Eine 100% Garantie können aber auch wir nicht geben - tut keiner in der Recovery Business Welt.

    Falls Interesse besteht - bitte per PN bei mir melden.

    Grüße
    Hallo,

    hab mich vorhin bereits entschlossen dem Tutorial folgend zu "degraden", aus folgendem vermutlich zwingenden Grund:

    Ohne Neu-Aufsetzen und Formatieren des Arrays werd ich dieses Problem mit den falschen Windows-Permissions wohl nicht los.

    Bin also bereits am Dateien extrahiern...
    Danke nochmal für die Unterstützung!
    --
    Mit erwartungsvollen Grüßen,
    -- uni,nett