QB-35US3R (Raid 5) - 1. Platte defekt, QB nicht ansprechbar, Lösungssuche

    QB-35US3R (Raid 5) - 1. Platte defekt, QB nicht ansprechbar, Lösungssuche

    Hallo und guten Morgen,

    bei mir verhält sich ein QB-35US3R etwas ungewöhnlich. Im Einzelnen:
    • HDD error LED leuchtet rot
    • Fehler-LED der obersten Platte leuchtet rot
    • bei Anschluss über USB 'erwacht' das QB-35US3R, meldet sich aber nicht am Host (3 verschiedene Hosts jeweils mit USB2.0 und USB3.0, Linux-Syslogs bleiben leer, Windows bleibt still)
    • bei Anschluss über SATA passiert wohl etwas (nur in Linux-Syslogs), schlussendlich wird jedoch keine Platte am System angemeldet. Bei Windows ist gar nichts zu bemerken.
    Während ich die LED-Fehlermeldungen noch klar einordnen kann, so bin ich doch etwas verwirrt ob der Anschlussproblemetik.
    ​Obwohl es für alle wichtigen Daten aktuelle Backups gibt würde ich doch gerne versuchen das QB-35US3R wieder zum Laufen zu bringen oder zumindest Zugriff auf alle Daten (auch die 'unwichtigen', deren Wiederherstellung doch einige Wochen in Anspruch nehmen würde) zu erhalten und suche nach dem optimalen (oder gar optimalsten) Weg, dies zu erreichen.

    Meine Ideen und Überlegungen:
    • Platte 1 ersetzen
      • Rebuild könnte funktionieren, Zugriff wird vermutlich nicht funktionieren, oder?
    • neues Gehäuse (irgend etwas 'kompatibles') und eine neue Festplatte
      • keine Ahnung ob das funktioniert, oder ob ich damit auch die 'Restdaten' in Staub verwandle. Funktioniert das?
    • Platten einzeln sichern (die 3 Überlebenden) und mit Thirdparty-Tools wieder herstellen.
      • gibt's da eine Lösung/ein Werkzeug oder eine Beschreibung des Formats der einzelnen Platten im RAID5 Modus?
    Bisher habe ich die einzelnen Platten noch nicht genauer untersucht, kann also zum wirklichen Zustand der ersten Platte nichts sagen.

    Kann mir hier jemand bei meinen Ansätzen weiterhelfen oder hat gar eine Lösung?


    Einen wunderschönen Mittwoch und vielen Dank,

    timpi.
    Hallo,

    Deine Umschreibung ist so insgesamt sinnig und nachvollziehbar aufgebaut, doch eine entscheidende Info kann ich leider nirgends, oder besser gesagt nur beiläufig finden - Der Raid Level. :thumbup:

    Welcher Raid Level ist denn eingestellt? Du hast zwar unten mal kurz Raid 5 erwähnt, aber ich würde das schon ganz gern noch mal mit Bestimmtheit bestätigt haben.

    Also grundsätzlich ist bei diesem Raid Level tatsächlich erst mal die defekte Platte gegen einen identischen Datenträger auszutauschen, wenn Dir das QB den vermeintlichen Übeltäter schon anzeigt.
    Du wirst dann sofort sehen, ob das QB mit einem Rebuild beginnt oder nicht. Bis dahin sind in dem Zustand die restlichen Platten auch erst mal safe, so denn sie nicht bereits auch defekt sind oder gar die Raid Level Struktur beschädigt ist.

    Über die restlichen Punkte würde ich mir daher erst danach Gedanken machen, denn bis hier hin scheint die Fehlererkennung des QB ja zu funktionieren.

    Würde das QB allgemein einen Fehler ohne speziellen Hinweis auf eine Platte anzeigen, könnte man in der Tat auch einen Gehäusedefekt ins Auge fassen.

    Fakt ist, eine neue Platte zu besorgen wäre so oder so angebracht und bevor Du gleich auch noch das Gehäuse wechselst, würde ich schon erst mal einen Rebuild testen.

    Die Gefahr den kompletten Verbund zu zerschießen, in dem Du alle Platten entnimmst, ohne Platte 1 nicht im QB ausgetauscht zu haben, könnte weitere Bemühungen ad absurdum führen.

    Grüße

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „paddylein“ ()

    Hallo paddylein,

    vielen Dank für die Antwort. Ja, es handelt sich um ein Raid 5. Eine neue Platte habe ich auch schon geordert.

    Was mich verwundert ist, dass ja ein Raid 5 bei Ausfall einer Platte weiterarbeiten sollte. Hier jedoch scheinen weder der USB- noch der SATA-Port davon zu wissen und das verwirrt ein wenig.
    Aber ich werde mal den Rebuild-Versuch abwarten.


    Viele Grüße,

    timpi.
    Hallo,

    grundsätzlich hast Du recht, aber darauf kann man sich nicht immer verlassen.
    Soweit ich weiß, beziehen die QB's ihre Raid Informationen direkt vom ersten Datenträger - das könnte eine Erklärung sein, muss es aber nicht.

    Dass man hier leider etwas raten muss, ist einfach dem Preis der QB's geschuldet. Bei weitaus teureren Standalone Lösungen hast Du natürlich weitaus mehr Komfort, durch mächtige UI's, in denen Du Dir die erkannten Fehler genau ansehen kannst, einzelne Platten aushängen kannst, ohne den Verbund zu beschädigen etc., eben wie unter Linux!

    Aber ich denke, wir warten jetzt erst mal ab, was das QB zur neuen Platte sagt, denn die aktuelle wird ja defensiv als defekt angezeigt. Und der Meldung sollte man da erst mal glauben.

    Wie man das mit dem Platten Wechsel bewerkstelligt, damit bist Du betraut? Dann erspare ich mir dahingehend die Erklärungen. :thumbup:

    Grüße

    p.s. ich habe mal die Threadüberschrift geändert. Sollte sich ein anderes Fehlerbild ergeben, können wir das ja dann noch mal ändern. Aktuell sehe ich erst mal keinen Defekt am QB selbst.
    Hallo paddylein,

    ich vermutete auch einen Zusammenhang mit der ersten Platte (die sollte ja immer bestückt sein) und dem 'nicht mehr sehen' vom Host. Drücken wir mal die Daumen, dass es wirklich daran liegt.
    Den Plattenwechsel bekomme ich schon hin, danke der Nachfrage. Ich werd' mich wieder melden, wenn es etwas Neues gibt.

    Danke und viele Grüße,

    timpi.
    Hallo und einen guten Abend,

    hier mal ein kurzer Zwischenstand, da die gelieferte Ersatzplatte leider defekt hier ankam und ich noch nicht testen konnte, ob das Rebuild klappt.
    Allerdings habe ich die vermeintlich defekte Platte mal angeschaut und die SMART-Werte sehen hervorragend aus. Ein Lesetest lief tagsüber und die komplette Platte konnte fehlerfrei gelesen werden. Ich bin mir mittlerweile fast sicher, dass die Festplatten in Ordnung sind und die Elektronik ausgestiegen ist.
    Die Frage, die sich mir jetzt stellt: wie mache weiter?

    Ein schönes Restwochenende wünscht

    timpi.
    Hallo,

    ​Die S.M.A.R.T. Werte sind nur ein Indikator für einen möglichen, physischen Defekt einer Platte, keinesfalls muss das aber bedeuten, dass die Platte zu 100% OK ist. Es braucht nur ein schleichender oder temporär auftauchender Defekt an der Platte existieren und die S.M.A.R.T. weisen Dir keinen, bzw. den falschen Weg.
    ​Nur mal so als Beispiel, in acht von zehn Fällen uns für Recovery Fälle überantwortete Platten waren nachweislich Defekt, in den S.M.A.R.T. Werten jedoch unauffällig.
    Vergiss bitte auch nicht, dass Raid Systeme empfindlicher sind. Die kleinste Ungereimtheit und die Controller melden die Platte als Defekt. Es ist natürlich auch möglich, dass die Raid Infos zerschossen wurden.

    ​Wenn ich Du wäre, würde ich mich noch ein wenig in Geduld üben und erst mal auf eine neue Platte warten.
    ​Die Erfahrung zeigt, dass wenn das Raid Gehäuse defekt ist, in der Regel nur ein Fehler angezeigt wird, ohne dabei eine spezielle Platte als defekt zu deklarieren.

    ​Wenn Du Dir Deiner aber so sicher bist, dass die Festplatte keinen Defekt aufweist, kannst Du diese ja am Rechner einmal komplett leeren (nicht formatieren, sondern sämtliche Partitionsinhalte löschen) und dann die Platte wieder in das QB einbauen. Entweder startet der Rebuild Vorgang oder aber die selbe Platte wird Dir wieder als Defekt angezeigt.

    Grüße
    Hallo,

    Wenn einmal etwas schief geht... so die neue Platte ist endlich da.
    Nach dem Ersetzen der ersten Festplatte durch die neue sieht das Fehlerbild ein wenig anders aus:
    • nach den Starten leuchtet die HDD error LED rot, allerdings sind die vier Fehler-LED der Festplatte aus
    • das Verhalten beim Anschluss über USB oder eSata hat sich nicht geändert.
    timpi.
    Hallo,

    timpi schrieb:

    nach den Starten leuchtet die HDD error LED rot


    ​das irritiert mich jetzt ein wenig. Bitte beschreibe mal genau, wie Du nach der Ankunft der Platte vorgegangen bist.

    Normal hättest Du wie folgt vorgehen müssen.

    ​1. vermeidlich defekte Platte so lange im QB belassen, bis die neue eingetroffen ist.
    ​2. Ist die neue eingetroffen, schaltest Du das QB im Urzustand, ergo mit der vermeidlich defekten Platte ein, wartest, bis das QB hochgefahren ist, öffnest dann die Front im laufenden Betrieb und wechselst ebenfalls im laufenden Betrieb die defekte gegen die neue Platte.
    ​3. Nun sollte die Rebuild LED beginnen zu leuchten - und das bleibt so lange, bis das QB mit dem Rebuildvorgang fertig ist.

    ​Das kann je nach Größe und Platte einige Stunden, bishin zu einem kompletten Tag und mehr dauern.

    Bist Du exakt so vorgegangen? ​Hat bei Dir überhaupt schon der Rebuildvorgang gestartet?

    Grüße
    Hallo paddylein,

    danke für die schnelle Antwort. Ich hatte vor einiger Zeit schon mal eine Platte gewechselt und kann mich erinnern, dass das Rebuild innerhalb weniger Minuten anfing. Damals wie heute habe ich die Platte im ausgeschalten Zustand getauscht (wurde mir so vom Händler gesagt, die QB-35US3R sei nicht hotplug-fähig). Das hatte beim ersten Tausch problemlos geklappt.
    Der Rebuildvorgang selber wurde noch nicht gestartet (laut LED), vielleicht sollte ich noch etwas warten?

    timpi.
    Hallo,

    timpi schrieb:

    wurde mir so vom Händler gesagt, die QB-35US3R sei nicht hotplug-fähig


    ​Das hat nichts mit Hot Plug fähig, sondern allgemein gültiger Raid Norm zutun. Das ist nun mal die reguläre Methode zum auswechseln defekter Datenträger. Wenn das bei Dir damals mit dem Tausch der Platten im ausgeschalteten Zustand geklappt hat, war das wohl eher ein Zufall. Ich bezweifele auch stark, dass es was bringt, länger zu warten. Der Start dauert in der Regel keine Minuten sondern eher Sekunden!

    ​Wenn Du Pech hast, ist der Raid Verbund jetzt zerschossen. Du kannst nur folgendes probieren:

    ​QB ausschalten, defekte Platte wieder einsetzen, QB einschalten und hoffen, dass es Dir wieder den alten Fehler anzeigt. Ist dem so, gehst Du noch mal so vor, wie von mir beschrieben.

    ​Wenn auch das nicht klappt, sieht es verdächtig nach einem zerschossenen Raid Verbund aus.

    ​Grüße
    N'Abend,

    vielen Dank erstmal.

    paddylein schrieb:

    allgemein gültiger Raid Norm

    Hmm, welche denn? Das Fantec ist nicht das erste Raid, dass ich betreibe, allerdings das erste Lowcost-Raid. Trifft Deine Aussage nur für solche Geräte zu? Denn bislang war es meinen Raid-Systemen (Software, Fake oder Hardware) ziemlich egal wie ich die Festplatte gewechselt habe. Entweder startete das Rebuild von alleine oder ich hatte die Möglichkeit es anzustupsen.

    paddylein schrieb:

    sieht es verdächtig nach einem zerschossenen Raid Verbund

    Möglich, aber das Ganze erklärt immer noch nicht, warum USB tot ist. Das ist dann wohl eher ein Hardwareproblem. Oder funktioniert USB nicht (also wirklich gar nicht, nicht eine syslog Meldung), wenn der Raidverbund kaputt ist?

    Gibt es eigentlich irgendwo Informationen zum von JMicron benutzten Superblock-Format?

    timpi.
    Hallo, Guten morgen trifft es wohl eher :thumbsup: ,

    timpi schrieb:

    Hmm, welche denn? Das Fantec ist nicht das erste Raid, dass ich betreibe, allerdings das erste Lowcost-Raid. Trifft Deine Aussage nur für solche Geräte zu? Denn bislang war es meinen Raid-Systemen (Software, Fake oder Hardware) ziemlich egal wie ich die Festplatte gewechselt habe. Entweder startete das Rebuild von alleine oder ich hatte die Möglichkeit es anzustupsen.


    ​Das Grundprinzip von Raid ist einfach mal die Tatsache, dass man so ziemlich alles im laufenden Betrieb erledigen können soll (entgegen der allgemein gültigen Regeln aus dem PC Bereich, Festplatten z.B. nur im ausgeschalteten Betrieb zu wechseln) - eben damit der Regelbetrieb gewährleistet ist. Selbst im Business Betrieb werden Platten on the fly getauscht und nicht extra die Server für runtergefahren und wie bekannt sein sollte, ist die Raid Geschichte ja dem Business entsprungen. :thumbup:

    ​Klar, wer über ein Hard- oder Soft Raid System verfügt, bei dem man manuell einzelne Platten ein- und aushängen kann, da kann man dann auch andere Methoden wählen. Beim QB übernimmt aber jegliche Arbeit das QB selbst. Dank ausgeklügelter Entwicklungen ist im Raid Bereich für Consumer derweil vieles möglich. Vieles, dass eigentlich nichts mehr mit den ursprünglichen Raid Normen zutun hat. Deshalb ist es auch nicht immer leicht, Raid Verbünde zu portieren, wenn man einen Systemwechseln vornimmt. Je nach Hardware Raid kann das richtig stressig werden.

    timpi schrieb:

    Möglich, aber das Ganze erklärt immer noch nicht, warum USB tot ist.


    Türlich tut es das. Was soll Dir denn der Rechner anzeigen, wenn der Raid Verbund zerschossen ist? Nix, korrekt, rein gar nichts. :thumbup: ​Erst bei einem korrekt eingerichteten Raid Verbund kann der Controller ein für den PC erkennbares Laufwerk über USB / eSATA ausgeben, dass dann über den PC erkannt und eingerichtet werden kann.

    timpi schrieb:

    Gibt es eigentlich irgendwo Informationen zum von JMicron benutzten Superblock-Format?


    ​Kann ich Dir jetzt leider nachts um 2 so auf die schnelle leider nicht mit dienen :D . Kann aber gern schauen, ob ich das jetzt am WE in Erfahrung gebracht bekomme.

    ​Grüße
    Hey, noch munter, einen wunderschönen guten Morgen wünsche ich ;),

    paddylein schrieb:


    Türlich tut es das. Was soll Dir denn der Rechner anzeigen, wenn der Raid Verbund zerschossen ist?


    Naja, zumindest der USB-Controller (also hier der JMS539) sollte sich melden. Das ich keine Festplatteninformationen geschweige denn Partitionsdaten zu sehen bekomme ist mir klar. Aber selbst den Controller sehe ich nicht (Linux-Syslogs). Mir ist auch bekannt, dass ältere Linux-Versionen Probleme im USB3-Betrieb mit dem JMS539 haben, dass hab ich schon durch....
    Ist übrigens das zweite Fantec-Gerät, das diese Phänomen zeigt (eSata ja, USB nein bei einem Fantec DB-ALU3e mit ASMedia-Chipsatz), vielleicht bin ich da etwas vorbelastet.

    Das Grundprinzip von Raids ist mir schon klar, ich habe eher ein Problem mit "Assistenzfunktionen", die ich nicht nachvollziehen kann (besonders verbreitet im Consumerbereich jedoch nicht nur bei Raids). Für mich erschwert so etwas eher den Einsatz solcher Geräte, bzw. die Ursachenforschung im Fehlerfall

    Wenn Du nähere Informationen zum JMicron-Format hast wäre ich Dir sehr dankbar. Selbst baidu, dass sonst fast immer weiterhilft, konnte mir bislang nicht antworten.

    Ein sonniges Wochenende wünscht

    timpi.

    [UPDATE] Hat sich erledigt mit dem JMicron-Format. Hab's rausbekommen und brauche jetzt nur noch ein wenig temporären Plattenplatz um hoffentlich alles wiederherstellen zu können. Zumindest die ersten 30GB an Daten (mehr Platz habe ich derzeit nicht für die Images) konnte ich lesen. Sind zwar noch Paritätsfehler in zwei Blockgruppen, aber da muss ich mal schauen. Vielleicht habe ich aber auch noch einen Fehler gemacht.
    Wenn Du allerdings noch Hinweise hast, was mit dem Fantec los sein könnte, dann wäre ich durchaus interessiert daran.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „timpi“ ()

    Hallo,

    timpi schrieb:

    Wenn Du allerdings noch Hinweise hast, was mit dem Fantec los sein könnte, dann wäre ich durchaus interessiert daran.


    ​aus der Ferne leider nein. Sofern die von mir beschriebene Methode zur Initialisierung eines Rebuildvorgangs nicht zum Erfolg führt, wirst Du nur durch ein komplettes neu Aufsetzen herausfinden, ob das QB selbst noch ordnungsgemäß funktioniert. Im Idealfall kann man das natürlich mit 4 Referenzplatten testen.

    ​Ich denke aber, die Tipps, die ich Dir hier über das Forum maximal angedeihen lassen kann, über die bist Du bereits selbst im Bilde. Die letzte Option wäre sonst nur noch, das QB zwecks Überprüfung einzusenden, sofern die Gewährleistungszeit noch greift. Wenn das nicht der Fall ist, kann ich Dir nur mal anbieten, dass wir hier (nicht Fantec, siehe Signatur) uns das Gerät mal anschauen. Wir haben da auch noch mal die eine oder andere Option.

    ​Aber ich denke, Du kannst ja erst mal mit Deinen Versuchen fortfahren. Nur denk dran, eben weil Du auf das QB wenig bis gar keinen Einfluss hast - bastel nicht zu viel an dem Verbund rum. Das QB lässt sich nicht unbedingt zwingen, Deine Versuche der Wiederherstellung zu akzeptieren. :thumbup: Im Zweifel hilft wirklich nur noch komplett neu aufsetzen.

    ​Backups sind bei Raid Systemen natürlich immer vorausgesetzt aber ich bin guter Dinge, dass Du das weist. :D

    Grüße