"Database not ready" - "Keine Daten" - wo ist die Musikbibliothek?

    "Database not ready" - "Keine Daten" - wo ist die Musikbibliothek?

    Zwei Probleme mit der Musikbibliothek

    1. Eigentlich sollte zuerst eine Liste von Titeln gezeigt werden, also von den in den ID3-Tags vermerkten Titeln, das S3600 zeigt aber nur die Dateinamen. Das bringt natürlich nicht viel, weil die meist nur sehr kurz gehalten sind, zusammengesetzt aus Kürzeln für Komponist+Komposition sowie Nr. des Datenträgers und des Tracks. Nur für das Betriebssystem... Meine Handies machen das richtig.

    2. Wenn ich dann die Menutaste drücke, und eine Anzeige nach Alben oder nach Interpreten haben möchte, dann bleibt die Anzeige leer und oben drüber steht, "Keine Daten" oder "Database not ready".

    Könnte es sein, daß eine richtige Datenbank nur auf der eigentlichen Festplatte am eSATA-Port angelegt wird? Ich hab im Moment nur eine 32-GB-Speicherkarte im SD-Kartenslot (Laufwerk "C:") und einen 4-GB-Speicherstift am seitlichen USB-Port (Laufwerk "D:") angeschlossen (am eSATA-Port nur ein Leergehäuse, für das erst noch ein Laufwerk angeschafft werden soll; der rückseitige USB-Port soll den Strom liefern).

    Hängt damit auch zusammen, daß das Video als MP4-Datei auf dem USB-Stick erst nach langer Zeit als Video anstatt als Musik erkannt wird, und daß diese Erkenntnis vergessen wird, wenn das Gerät mal ausgeschaltet wird?
    Zuerst mal Hallo, ich denke so viel Zeit für Höflichkeit sollte an so einem schönen Wochenende noch sein :thumbup: ,

    Beobachter7 schrieb:

    Könnte es sein, daß eine richtige Datenbank nur auf der eigentlichen Festplatte am eSATA-Port angelegt wird?


    Nein, die Medienbibliothek funktioniert mit ALLEN stationär angeschlossenen Datenträgern. Allerdings muss zu Anfang erst mal ein Scan dieser erfolgen. Auch ist wichtig zu wissen, ob die ID3Tags sauber sind. Siehe dazu unser ID3Tag Tutorial.

    Deinen Beitrag zum Thema Uni-FB habe ich übrigens mal in den entsprechenden Thread verschoben und halbwegs angepasst - dafür gibt es nämlich bereits einen Bereich. :thumbsup: Wäre klasse, wenn Du da noch die fehlenden Angaben ergänzt. Z.B. aktuelle Firmware des Players etc..

    Grüße
    Meine Höflichkeit besteht darin, mich auf das Wesentliche zu konzentrieren, und die Leser nicht mit Höflichkeitsfloskeln zu belästigen... aber wenns gewünscht ist, schreib ich gerne noch "Guten Morgen" auch für die, die das erst am Abend lesen...

    Die ID3-Tags sind in Ordnung. Meine Handies zeigen die allesamt ordentlich an, PC-Abspielsoftware ebenso.

    Und der S3600 zeigt das Feld "Album" ja auch beim Abspielen korrekt an, indiziert aber anscheinend die Datenbank nicht danach. Oder braucht eine Ewigkeit dafür, und kann die aber dann nach Ausschalten vielleicht nicht abspeichern.

    Aber es gibt auf der Speicherkarte einige Dateien, die nur Tags nach Version 1 haben, und ein paar wenige ganz ohne Tags - das sind Dateien, die ich nicht selbst erstellt habe. Das sollte aber nicht die Erstellung eines Index nach "Album" und "Interpret" verhindern; man würde die unter "unbekannt" oder "unkown" einordnen.

    Ich erstelle die MP3s mit Audiograbber und bearbeite die Meta-Daten dann mit ID3-TagIT version 3.2.1 (die jüngere 3.3 ist nicht zu empfehlen, weil noch in so einer Art Alpha-Test-Phase, bevor der Entwickler sein Produkt aufgegeben hatte).

    Verstehe ich das richtig, daß die Software des S3600 auch ID3-Tags nach Version 2.4 verstehen würde?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Beobachter7“ ()

    Hallo,

    Beobachter7 schrieb:

    Meine Höflichkeit besteht darin, mich auf das Wesentliche zu konzentrieren, und die Leser nicht mit Höflichkeitsfloskeln zu belästigen... aber wenns gewünscht ist, schreib ich gerne noch "Guten Morgen" auch für die, die das erst am Abend lesen...


    also wenn ich den morgendlichen Bäckerbesuch absolviere, spare ich mir meine Höflichkeit auch nicht aus Zeitgründen und ich empfinde diese auch nicht als Floskel, sondern als Tat einer guten Kinderstube, auch wenn solche Werte heute offensichtlich nicht mehr so ganz gefragt sind. ^^
    Hier im Forum empfindet Höflichkeit jedenfalls niemand als belästigend - im Gegenteil, wir sind dahingehend relativ oldschool und freuen uns über jedes freundliche Wort :!: .

    Aber zurück zum Thema!

    Beobachter7 schrieb:

    Die ID3-Tags sind in Ordnung. Meine Handies zeigen die allesamt ordentlich an.


    Nun ja, die Tatsache, dass Deine Telefone das korrekt anzeigen, ist für uns erst mal kein Indikator, dass die ID3 Tag's zwingend korrekt sein müssen. Die Informationen danach, betreffend Bearbeitung, lassen da schon eher einen solchen Rückschluss zu.

    Soweit mir bekannt, unterstütz nicht nur dieser, sondern nahezu jeder ältere Standalone Hardware Mediaplayer ID3v1, maximal ID3v2, das kann ich Dir aber nicht zu 100% bestätigen. Evtl. ist dazu Lars (fantec) in der Lage.

    Was Du mir aber noch nicht wirklich beantwortet hast, ob Du denn auch mal manuell einen Scan nach Medien im S3600 durchgeführt hast? Ohne diesen Scan ist der Player nicht in der Lage, eine Datenbank zu generieren, geschweige denn über die Medienbibliothek korrekte Informationen anzuzeigen. Der Dateimanager himself, zeigt Dir in der Tat nur Dateinamen an. Es ist zwingend die Medienbibliothek zu nutzen!

    Grüße

    paddylein schrieb:

    Was Du mir aber noch nicht wirklich beantwortet hast, ob Du denn auch mal manuell einen Scan nach Medien im S3600 durchgeführt hast?


    Nein, das läuft doch immer automatisch, und selbst nach einer Unterbrechung mit der STOP-Taste gehts immer wieder automatisch los. Ich vermute, daß es eben doch am Fehlen der eSATA-Festplatte liegt, v.a. wenn ich im Handbuch lese
    "Der Player setzt zur Datenspeicherung eine externe eSATA-Festplatte ein" (Abschnitt 1.3.6 - leider kann man aus dem Handbuch nicht kopieren...).

    Vielleicht fehlt dem System auch seine Uhrzeit, aber die kann ich nicht einstellen (nur Zeitzone, Sommerzeit, 24/12-Stunden-Anzeige).

    Ich für meinen Teil empfinde es als ausgesprochen unhöflich, von fremden Menschen ungefragt geduzt zu werden, und mache das aus Höflichkeit selber auch nicht.
    Hallo,

    Beobachter7 schrieb:

    Ich für meinen Teil empfinde es als ausgesprochen unhöflich, von fremden Menschen ungefragt geduzt zu werden, und mache das aus Höflichkeit selber auch nicht.


    Das ist in Internet Foren dieser Art im Allgemeinen üblich - davon aber mal angesehen, wollen wir das Thema jetzt wirklich unnötig auskleiden??? Tut glaube ich nicht Not. ;)

    Beobachter7 schrieb:

    Nein, das läuft doch immer automatisch,


    Tut es mitnichten. Die Scan Funktion lässt sich nämlich auch über das Setup deaktivieren - dass dies bei Dir nicht der Fall ist, kann ich leider nicht riechen :thumbup: . Darum die Frage.

    Für die Anzeige korrekter ID3 Tags ist die Uhrzeit völlig unerheblich.

    Darüber hinaus habe ich die Situation gerade mal auf einem unserer Test-S3600 probiert.

    - USB Stick mit MP3 am Player eingesteckt
    - Scan durchgeführt
    - Medienbibliothek für Musik aufgerufen, und frei nach Alben, Genre etc. sortiert und eine einwandfreie Anzeige erhalten!!!
    - danach parallel zum Stick eine SD-Card eingesteckt, ebenfalls mit MP3's
    - gewartet, bis der Scan durchgeführt war
    - Medienbibliothek für Musik aufgerufen, alles wurde angezeigt - beide Speichermedien!

    Der S3600 ist mit keinem Netzwerk verbunden gewesen und es ist auch keine eSATA Platte verbunden, ausschließlich der USB Stick war angeschlossen.

    Folgende Optionen gibt es nun:

    - die entsprechenden Speicherdateien auf dem Stick oder der SD Karte wurden beschädigt oder von Dir fälschlicherweise gelöscht.
    Das betrifft die .part Datei, ebenso, wie den Theater Ordner. Das sind die Speicherdateien des Players. Lösche diese bitte mal mittels PC und lass den Player die Daten noch mal neu einlesen. Bitte Datenträger für Datenträger. Nicht beide gleichzeitig.
    - nächste Option wäre ein defekter Stick oder eine defekte SD Card.
    - eine weitere Option sind inkonsistente Datenträger. Inkonsistenzen treten gerne immer dann auf, wenn man den Speicher nicht ordnungsgemäß vom jeweiligen Rechner abmeldet, bevor man ihn entfernt.
    Sollte Dein Rechner beim einstecken der Datenträger sagen, dass was nicht in Ordnung ist und eine Fehlerüberprüfung gemacht werden sollte, ist das ein Indiz dafür. Es kann aber auch ein Indiz für einen defekten Flash Speicher sein.

    Es gibt im Netz Tools, mit denen man speziell Flash Speicher, wie eben Sticks und Karten formatieren kann. Diese würde ich mal testen, wenn es keine beschädigte Datenbank ist.

    Mir wurde hier nur bei einem Szenario kein Ergebnis in den Medienbibliotheken geliefert - und zwar, wenn im Setup die Autoscan Funktion deaktiviert war.

    Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „paddylein“ ()

    Ich hab die SD-Karte vor längerer Zeit in den S3600 gesteckt, und m.W. dann nie wieder angerührt. Von einer .part-Datei weiß ich überhaupt nichts. Ich will aber nicht ausschließen, daß ich die SD-Karte mal im ausgeschalteten Zustand des S3600 herausgenommen habe, kann mich aber an nichts dergleichen erinnern.

    Aber ich werd die SD-Karte mal freigeben, rausnehmen und am PC überprüfen (der S3600 ist nicht am Netzwerk). Ich muß sowieso einen ganzen Ordner darin ersetzen, oder sogar mehrere, weil die Metadaten in diesen Dateien fehlten oder fehlerhaft waren, und weil einige Dateinahmen in keinster Weise meinen Vorstellungen entsprachen (die hatte ich von einem Freund bekommen).

    Noch eine Beobachtung zu den ID3-tags:
    die werden ja sowohl beim Vorspiel als auch in einer Liste nach Titeln mit der Option "Vorschau" werden Artist, Album, Genre usw richtig angezeigt, der Apparat erstellt nur keinen Index auf diesen Feldern, sondern ausschließlich auf Titel.

    Ich meld mich wieder, wenn ich mehr weiß.

    Nachtrag: ein erster Hinweis, nach Ansicht der SD-Karte im PC: die "stx.db" ist 2496 kB groß, es sind dann aber nur noch 96 kB Speicher übrig auf dem Datenträger. Ich hatte schon dran gedacht, daß vielleicht einfach der Speicherplatz für die zusätzlichen Indizi fehlt.

    Weitere Anwort am nächsten Morgen (als Änderung, weil eine Anwort seitens der Forumssoftware nicht möglich ist):
    Paddylein empfahl die Datei .part und den Ordner .Theater zu löschen, und das Gerät die Daten neu einlesen zu lassen.
    Das hab ich gemacht, aber das war anscheinend keine gute Idee. S3600 partitioniert sich die SD-Karte selbst mit einer versteckten Partition am oberen Ende, mit der Windows nichts anfangen kann (die Verwaltung für Datenträger zeigt die Existenz davon an, allerdings mit einem Phantasiewert für die Größe, ca. 2500 GB. Und die .part zeigt dem System vermutlich, an welchem Sektor oder Bytemarke diese Partition anfängt.

    Ich hab dann auch noch große Teile meiner Dateien auf der SD-Karte gelöscht, und somit viel Platz geschaffen.

    S3600 hat dann eine neue .part und das Verzeichnis für die Datenbank neu angelegt.

    Die ursprüngliche .part beinhaltete Hex 4a9c146e, die dann neu angelegte hex 3445cef2.

    Die neue Datenbank war dann wesentlich größer, 4881 kB. S3600 hat dann aber überhaupt nichts mehr angezeigt, auch nicht die Dateinamen (die die Software fälschlicherweise als Titel deklariert).

    Die Tabelle der eigentlichen Dateien (ExtHDDFile) enthät 5150 Sätze, aber die Tabelle der ID3 Tags AudioFieldSummary ist leer (ausgelesen mit dem SQlite Forensic Explorer).

    Ich müßte die SD-Karte neu formatieren, und den S3600 mit einem (für ihn) jungfräulichen Datenträger neu anfangen lassen, aber mein SD-Formatter (version 3.5 von Panasonic) sagt, er könne die Karte nicht formatieren. Ich brauch nen anderen. Aber jetzt muß ich erstmal für 2 Stunden ausm Haus.




    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „Beobachter7“ ()

    Hallo,

    Du musst den Beitrag einfach nur auf "NEU" setzen, dann sehen wir, dass Du ihn editiert hast :thumbup: .

    Und was nun das eigentliche Problem angeht, warum machst Du es denn so kompliziert? Nimm doch bitte einfach mal eine andere SD Karte, auch mal wahlweise eine Stick und formatiere diese entsprechend. Dann packe bitte mal drei bis 4 MP3 drauf und teste das Ganze.

    Wenn SDFormatter die SD Karte nicht formatieren kann, ist das ein sehr deutliches Inditz dafür, dass die SD Karte defekt sein könnte. Auch die Tatsache, dass da plötzlich eine nicht lesbare Partition erscheint. Der Player richtet nicht einfach so aus dem Stehgreif irgendwelche Partitionen auf Speichermedien ein. Auch das ist so erst mal ein Anzeichen, dass da irgendwas mit dem Speicher nicht stimmt.

    Grüße
    Wenn SDFormatter die SD-Karte nicht formatieren kann, dann liegt das u.U. auch daran, daß der USB-KArten-Adapter kein SDHC schreiben kann. Die nicht zugewiesenen Bereiche auf der SD-Karte ergeben sich vmtl. aus der Blockgröße der FAT32, wo je nach Blockgröße eben was übrigbleibt.

    Andere SD-Karte... ich hatte ja eine 64-GB-SD-Karte für den S3600 angeschafft, aber nach Anfrage bei Fa. Fantec wurde ich beschieden, daß der S3600 maximal 36 GB kann. Auf die 64er wäre meine ganze Musik draufgegangen... Das war die erste Enttäuschung. Die zweite Enttäuschung, das nur nebenbei, war der MP3-Spieler, der am analogen Ausgang ziemlich dumpf klingt.

    Was die Musikbibliothek angeht, so scheint das von mir oben beschriebene Problem daran zu liegen, daß die Software des S3600 den weiteren Aufbau der Musikbibliothek abbricht, sobald der auch nur eine MP3-Datei ohne ID3 Tags findet. Nun hatte ich an der Wurzel des MUSIK-Verzeichnisses so ein paar Fundstücke, die eben keine Tags hatten. Die sollte die Software dann aber jeweils unter "other" einsortieren können.

    Wirklich blöd ist, daß in den Listen beharrlich anstatt des Titels der Musik der Dateiname angezeigt wird, und das ist einfach nur falsch, denn der Dateiname hat mit dem Titel nichts zu tun

    Daß S3600 den Titel erkennen kann, sieht man beim Abspielen, wo der dann angezeigt wird, aber in einem viel zu kleinen Fester, wo die meisten Angaben dann trunkiert, will sagen, einfach abgeschnitten werden. Dafür steht dann ein völlig überflüssiges Symbol darüber. Das ganze Fenster beim Abspielen nutzt überhaupt nicht die ganze Bildschirmgröße aus, was noch ein Minuspunkt ist.

    Wenn ich ein Album abspiele, sollte der Titel des Albums oben über dem Fenster stehen, und in der Liste die Titel der in dem Album enthaltenen Stücke... Wenn "Artist", Komponist und/oder Textdichter für alle Stücke gleich sind, sollte das auch im Kopf angezeigt werden (trifft erst recht auf "Genre" zu), ansonsten sollte für individuelle Angaben pro Stück mehr Platz gelassen sein.
    Hallo,

    das ist mir alles viel zu viel Spekulation, solange das nicht mal mit einer anderen SD Karte oder eben auch einem Stick ausprobiert wurde.

    Bedenke dabei bitte auch, dass man SD Karten nur bedingt als Festplattenersatz nutzen kann/sollte. SD Karten sind nicht unendlich lange haltbar. Im Gegensatz zu Festplatten - deren Haltbarkeit in erster Linie anhand der Betriebsstundenzahl festgemacht wird, zählen bei einem Flash Speicher die Anzahl der Schreibzugriffe. Oft und viel genutzte SD Karten können gern auch mal schnell nach 1-2 Jahren in die Knie gehen, abhängig von Hersteller, SD Controller etc.!

    Und was die MP3's angeht, auch dazu kann man aus der Ferne nichts sagen. Wir haben das hier wie gesagt in allen Variationen einmal durchgetestet und es gab keinerlei Probleme beim Einlesen und verwerten der Daten. Wenn bei Dir nach wie vor nur der Dateiname angezeigt wird, ist da definitiv etwas falsch oder Du bewegst Dich nicht in den Bibliotheken, sondern im Dateimanager - klingt nämlich fast so, nachdem Du beschrieben hast, wie klein doch das Fenster sein soll, in dem Dir die Daten angezeigt werden.

    Grüße
    1. Die SD-Karte ist in ordnung.
    2. Ich halte eine normale Festplatte für viel anfälliger als SD-Karten, weil sie mechanisch bewegte Teile hat.

    3. Nun zum ursprünglichen Problem:

    Mir scheint jetzt, daß das Hauptproblem mangelnder Speicherplatz für die Datenbank war. Ich hatte weiter oben erwähnt, daß die stx.de 2496 Kilobytes groß war, und nur noch 96 kB freier Platz auf der Karte.

    In einem späteren Zustand, nach Löschen zahlreicher Dateien (Bilder, Texte u.ä.), die eben keine mp3-Dateien waren, war die stx.db 5069 Kilobytes groß. Das hatte aber vmtl. auch noch nicht gereicht.

    Ich hab dann die Karte formatiert (mit Windows-Bordmitteln), die Verzeichnisse wiederhergestellt und einen großen Teil der mp3-Dateien wieder draufkopiert. Jetzt sind 16,87 GB von 29,50GB frei. Danach wurden ja auch "Artist", Album u.a. ID3-Tags erkannt. Dann gab es eine stx.db von 2928 kB und erstmals eine stxcross.db von 2914 Kilobytes.

    Dazu hatte ich -- wie in meinem vorigen Beitrag erwähnt -- alle mp3-Dateien im Wurzelverzeichnis mit ID3-Tags versehen.

    Nunmehr wollte ich testen, ob es tatsächlich daran liegt. Ich hab für eine davon alle ID3-Tags entfernt. Die Gesamtzahl der Dateien hab ich nicht geändert, auch sonst keine Dateien geändert.

    Jetzt bricht allerdings der Scan immer viel zu früh und immer im selben Verzeichnis (Schubert) ab. Ich sehe allerdings keine Probleme in diesem Verzeichnis.

    Die stx.db ist 2110 kB groß; es gibt auch schon eine stxcross.db mit allerdings nur 81 kB.

    Immerhin kann man diese Datenbanken auf dem PC mit einem SQLite-Browser inspizieren...
    Hallo,

    sorry, ich weiß nicht, was wir Dir dazu noch schreiben sollen. Was war eigentlich noch mal der Grund Deiner Anmeldung hier im Forum? Wolltest Du technisch fundierte Hilfe oder einfach nur Deine Sichtweise der Dinge darstellen?

    Wenn Du unseren Supportlerischen Anweisungen/Hinweisen zur Fehleranalyse nicht folgen magst/glauben kannst, stattdessen mit seltsamen Herleitungen Deine eigene Vorgehensweise begründest, werden wir Dir hier schwerlich helfen können.

    Grüße
    'ne Frage wegen der Darstellung: Kann man denn in diesem Forum Bilder hochladen?
    Oder wirklich nur aus anderen Websites einbinden?

    Nachtrag um halb zwei:
    Ich gebs auf. Andere SD-Karten als die vorhandene 32GB-Karte hab ich nicht zur Verfügung, außer alten mit max 640 kB oder der eigentlich vorgesehenen 64GB-Karte.

    Einmal hats funktionert, nach einer kleinen Änderung wird überhaupt nichts mehr angezeigt.

    Immerhin kann ich mit dem Ding das eine MP4-Video anzeigen, das ist doch schon was.

    Nachtrag um zwei:
    Ich hab die Karte mit einem anderen USB-Adapter auf einem anderen PC mit einem neueren SD-Formatter neu formatiert, Daten wieder eingespielt -- es werden nicht mal die Dateinamen angezeigt. Ich hab in den letzten Tagen viele Stunden für das Problem aufgewendet, jetzt reichts mir.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Beobachter7“ ()

    Hallo,

    ich habe Dir mehrfach entsprechende Hinweise gegeben, wie Du erstmal ganz banales hättest ausschließen können, wenn Du diese ignorierst und lieber den komplizierten Weg gehen möchtest, dazu kann ich nichts. Statt Stundenlang mit irgendwelchen Tools in der Datenbank rum zu fuchteln, sagt die Logik: Datenträger tauschen/anderen testen!

    Dass Du nicht in der Lage bist, irgendein Speichermedium, egal ob SD Karte, USB Stick oder Festplatte zu Testzwecken zu beschaffen, kann ich wirklich schwerlich glauben. Eine einfache 4 GB SD Karte ist bereits für unter 10 EUR zu bekommen. Eine nagelneue 32 GB SD Karte von namhaften Herstellern ist bereits ab 11 EUR zu bekommen - soll es daran jetzt wirklich scheitern? 8o

    Grüße