Ray Play U3 - Untertitel (sup) funktionieren nicht bei MKV/MP4

    Ray Play U3 - Untertitel (sup) funktionieren nicht bei MKV/MP4

    Hallo,

    jetzt wollte ich doch mal nachfragen, ich habe des Öfteren Blu-rays, die ich mir entweder quasi unverändert im M2TS-Format auf die Festplatte lege oder manchmal auch z.B. mit MakeMKV umwandle. Dabei liegen die Untertitelspuren unabhängig vom Format erst mal als .sup vor.

    Im M2TS-Format kann ich problemlos eine Untertitelspur auswählen - funktioniert.
    Habe ich aber einen MKV-Container, dann kriege ich die Untertitelspuren zwar angezeigt (wenn ich mit der Fernbedienung auf Subtitle drücke), aber wenn ich sie auswähle, passiert nichts. In einem Softwareplayer wie z.B. VLC funktionieren die Untertitelspuren aber.
    Wenn ich die MKV-Datei mit den nicht funktionierenden Untertiteln wieder zurück konvertiere in M2TS, dann funktionieren auch die Untertitel plötzlich wieder.
    Zwischenzeitlich habe ich es auch schon mal mit .mp4 probiert, aber da ist es das gleiche - funktioniert nicht.

    Mein bisheriger Lösungsansatz (Konvertierung, wobei ich Bild-, Ton- und Untertitelspur auf "passthrough" stelle und das Ausgabeformat auf M2TS) ist halt dennoch etwas zeitaufwändig bei den großen Datenmengen einer Blu-ray.

    Ist das Problem bekannt?
    Gibt es da vielleicht irgendeinen "Kniff"?
    Moin,

    nicht MakeMKV verwenden, sondern XmediaRecode. :thumbup:

    Desweiteren funktionieren nicht alle Formate identisch und bei bestimmten Codierungen kann es erforderlich sein bei einem Format zu bleiben, z.B. m2ts.

    Ich würde aber dennoch erstmal mit XmediaRecode anfangen!

    Gruß,
    Lars