Umlaute, die II.

    Umlaute, die II.

    Kurz nach Inbetriebnahme meines Media Players "3DFHDL" Mitte 2012 habe ich hier im Forum schon einmal eine Diskussion geführt, dass man keine Umlaute eingeben kann (z.B. in Netzwerk-Passwörtern) und habe damals sinngemäß die Antwort erhalten, dass das halt so ist und ich halt ein Passwort ohne Umlaut nehmen solle.

    Heute hatte ich endlich mal Zeit, mich einem weiteren Problem zu widmen, welches vielleicht auf Umlaute zurück zu führen ist. Leider konnte ich es nicht weiter eingrenzen, aber vielleicht habt Ihr ja eine Idee, woran das liegen kann, wenn ich Euch das Fehlerbild kurz schildere.

    Ich habe mir auf meinem PC ein paar MP3-Playlisten im Format M3U per Texteditor erstellt und diese inklusive der zugehörigen MP3-Dateien auf den Player kopiert (externe USB-Festplatte). Die MP3-Dateien enthalten sowohl englisch-sprachige als auch deutsch-sprachige Lieder, bei den deutsch-sprachigen Liedern liegt es in der Natur der Sache, dass da im Interpreten oder im Titel der eine oder andere Umlaut vorkommt. Bei beiden Sprachen kommt auch ab und zu mal ein kaufmännischen Und (&) im Dateinamen vor. Alle MP3-Dateien enthalten ausschließlich den MP3-Tag in Version 1 (also den, der die letzten 128 Byte der Datei belegt).

    Nachdem ich mich immer mal wieder gewundert habe, dass die eine oder andere Playlist gefühlt doch recht kurz war, hatte ich dieses Wochenende das erste Mal seit langem den Fernseher an, um den Player zu bedienen, und dabei ist mir aufgefallen, dass anscheinend alle Lieder, die einen Umlaut im Dateinamen haben, mit der Meldung "Ungültige Datei" übersprungen werden.

    Zuerst dachte ich an einen Kopierfehler, habe also eine der betreffenden Dateien per WLAN direkt am PC abgespielt, und siehe da, das Abspielen funktionierte. Dann nahm ich diese Datei, veränderte den Dateinamen, den MP3-Tag bzw. beides und probierte jeweils, ob sich die Datei abspielen ließ, alle Kopien ließen sich abspielen, auch die originale (hier aber ohne Playlist drum herum).
    Also dachte ich an einen Fehler in der Playlist, aber diese sah im Texteditor gut aus.
    Also habe ich eine betreffende Playlist kopiert, zwei der betroffenen Lieder so umbenannt, dass sie keinen Umlaut und kein kaufmännisches Und (&) mehr im Dateinamen hatten (der MP3-Tag blieb unverändert) und den Verweis in der Playlist entsprechend geändert. Danach ließ sich eines der Lieder plötzlich auch über die Playlist abspielen, das andere meldete immer noch "Ungültige Datei".
    Hier war ich dann mit meinem Latein am Ende.

    Hatte einer von Euch auch schon mal dieses Fehlerbild und weiß, wie ich es beheben kann? Oder habt Ihr noch Vorschläge, was ich sonst noch testen kann, um den Fehler eventuell einzugrenzen?

    Auch ein Update auf die aktuellste Firmware v10.1.11 r11498 - 26. Mai 2014 brachte keine Besserung.

    Vielen Dank für die Hilfe.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Nostromo“ ()

    Moin,

    dass ist wie mit den Tags, die Geräte besitzen eine "internationale Basis" und diese Sonderzeichen, Umlaute, Freizeichen und Co. funktionieren da einfach nicht oder nicht gut, will man das nutzen also immer alles in "englischer Fassung" machen und auf unsere speziellen Zeichen und sowas verzichten!

    Siehe auch das Tag Tutorial, so sollten alle Dateien und Playlists funktionieren: Link

    Gruß,
    Lars
    Wie ich schon geschrieben habe, liegt es ja eben nicht an den Tags. Wählt man eine solche Datei direkt an, wird sie problemlos abgespielt und auch die Umlaute etc. werden korrekt angezeigt. Nur wenn man eine solche Datei per Playlist abspielen möchte, kommt es bei manchen Dateien zu der Meldung "Ungültige Datei" und bei anderen nicht.
    Ja, und nun? Soll ich alle meine MP3s umbenennen, weil Fantec einen lange bekannten Fehler immer noch nicht behoben hat???

    Und bei Umlauten bleibt es ja nicht, die Playlisten scheinen auch Case-Sensitiv zu sein, während es Dateinamen in allen mir bekannten Betriebssystemen nicht sind. Heißt die Datei abc.mp3 auf der Festplatte und in der Playlist wird auf Abc.mp3 verwiesen, wird sie schon nicht gefunden.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Nostromo“ ()

    Moin,

    dass ist doch kein Fehler, sondern einfach eine Begebenheit der Computerwelt. :thumbup:

    Windows und Mac verwenden "falsche" anzeigen für die Dateinamen, damit sowas wie von dir gewünscht funktioniert, systemnah geht das aber auch bei diesen Systemen nicht und bei Linux schonmal gar nicht, darauf beruhen die Player ja auch und da gibt es nunmal Case-Sensitive und einen internationalen Datensatz, der die Verwendung unserer Zeichen nicht zulässt.

    Entweder benennst du sie um oder du verwendest diese Funktion nicht, anders geht es nicht und das lässt sich auch nicht "beheben". :thumbup:

    Gruß,
    Lars