CL-35B2 - Http/ WebDav Access

    CL-35B2 - Http/ WebDav Access

    Grüße,

    Ich habe leider Schwierigkeiten, mich, via Win7 Client und der "finder.exe" auf meine nette NAS Box zu verbinden.
    ((Win7 x64 Professional Deutsch) - XP Client habe ich noch nicht probiert.... und muss ich mir erst aufsetzen)
    Infrastruktur:
    Router 1xinternes SubNet: ist.mei.nnt.xxx/24 DHCP: ON
    ist.mei.nnt.nas geht leider nicht
    Festplatten: sind derweilen ausgebaut
    Firmware: unbekannt
    Zugriff via Putti und telnet: OK (nur weiß ich nicht, was ich nun damit tun soll):

    Fedora release 12 (Constantine)
    Kernel 2.6.31.14-fast-20110801-fan on an armv6l (1)
    login: xxxxx
    Password:
    Last login: Fri Jul 11 20:19:01 from ist.mei.nnt.PC
    [xxxx@myfantec ~]$ ls -ls
    total 0
    [xxxx@myfantec ~]$ cd /
    [xxxxx@myfantec /]$ ls -ls
    total 12
    0 dr-xr-xr-x 2 root root 5880 2011-09-16 07:23 bin
    0 dr-xr-xr-x 3 root root 224 2010-07-23 00:29 boot
    0 drwxr-xr-x 11 root root 3140 2014-07-11 19:48 dev
    0 drwxr-xr-x 66 root root 10280 2014-03-23 19:06 etc
    0 drwxr-xr-x 6 root root 424 2013-01-01 14:51 home
    0 dr-xr-xr-x 10 root root 12000 2011-04-18 03:50 lib
    12 -rw-r--r-- 1 root root 8400 2013-01-02 19:39 list_right
    0 drwxr-xr-x 3 root root 232 2013-12-25 21:09 media
    0 drwxr-xr-x 2 root root 160 2009-10-08 16:01 mnt
    0 drwxr-xr-x 2 root root 160 2009-10-08 16:01 opt
    0 dr-xr-xr-x 78 root root 0 1970-01-01 01:00 proc
    0 drwxr-xr-x 3 root root 232 2013-01-01 14:51 root
    0 dr-xr-xr-x 2 root root 12208 2011-06-08 11:28 sbin
    0 drwxr-xr-x 2 root root 160 2009-10-08 16:01 selinux
    0 drwxr-xr-x 2 root root 160 2009-10-08 16:01 srv
    0 drwxr-xr-x 11 root root 0 1970-01-01 01:00 sys
    0 drwxrwxrwt 3 root root 304 2014-07-11 19:42 tmp
    0 drwxr-xr-x 13 root root 936 2010-07-23 00:26 usr
    0 drwxr-xr-x 19 root root 1456 2013-01-01 14:50 var

    Service Status:
    [XXXX@myfantec]$ service --status-all
    atd is stopped
    Avahi daemon is not running
    cupsd (pid 2424) is running...
    /etc/init.d/iptables: line 49: /etc/sysconfig/iptables-config: Permission denied
    lighttpd is stopped
    Usage: /etc/init.d/logbak {start|stop}
    mdmonitor is stopped
    dbus-daemon is stopped
    minidlna (pid 2578) is running...
    df: Warning: cannot read table of mounted file Systems ---> na klar, ohne HDs.
    chown: changing ownership of `/home/downloads/downloads.ini': No space left on device
    chown: changing ownership of `/home/downloads': No space left on device
    mldonkey is stopped
    mt-daapd is stopped
    nas-fastcgi is not running, nas-buttons is not running, nas-diskmon is not running.
    Usage: /etc/init.d/nasbakup {start|stop}
    Usage: /etc/init.d/nasled {start|stop|restart}
    Usage: /etc/init.d/nasmount {start|stop}
    atalkd is stopped
    papd is stopped
    timelord is stopped
    a2boot is stopped
    cnid_metad is stopped
    afpd is stopped
    netconsole module not loaded
    netplugd is stopped
    Configured devices:
    lo eth0
    Currently active devices:
    lo eth0
    rpc.mountd is stopped
    nfsd is stopped
    rpc.statd is stopped
    nmbd is stopped
    ntpd (pid 2474) is running...
    portreserve is stopped
    rdisc is stopped
    rpcbind is stopped
    rpc.idmapd (pid 2394) is running...
    rsyslogd is stopped
    smartd (pid 2764) is running...
    smbd is stopped
    sockproxy-daemon is stopped
    openssh-daemon is stopped
    vsftpd is stopped
    xinetd (pid 2450) is running...

    Den "Reset" auf der Rückseite zu drücken, hat überhaupt keine Reaktion / keinen Effekt zur Folge.
    Leider sind meine Linux Kenntnisse schlecht/ veraltert und Ich schon zu lange in der Microsoft Welt zu Hause....
    Irgend ein Tipp, den ich im Forum übersehen habe, um das Teil wieder ansprechen zu können?

    Vielen Dank im Vorfeld!
    Liebe Grüße,
    Tschortsch
    Hallo,

    eine Putti/Telnet Schnittstelle wird offiziell nicht unterstützt und entsprechend auch nicht supportet. Wer da dennoch was macht, tut dies auf eigene Gefahr. Wenn Du also selbst zugeben muss, da nicht der größte Überflieger zu sein, rate ich dringend davon ab.

    Die Reset Taste hast Du länger gedrückt? Einmal nur kurz drücken bringt nichts.

    XP musst Du übrigens nicht unbedingt aufsetzen, das sollte schon auch unter Win7 klappen. Wenn Router und B2 auf DHCP stehen, was sagt denn dann der Router? Wird dem B2 denn vom Router eine IP zugewiesen? Was passiert denn, wenn Du die IP in einem I-Net Browser eingibst? Damit solltest Du eigentlich ebenfalls zum Webinterface gelangen.

    Schon mal vorab die Frage, wie es denn um den Gewährleistungsstatus bestellt ist - Du wohnst in Deutschland und hast eine Rechnung, die das Gerät auf weniger als 2 Jahre datiert?

    Grüße
    Hallo - und vielen Dank für die Antwort!

    Gewährleistung:
    Ich habe das Ding von meinem Bruder übernommen, der sich nicht mehr zu helfen wusste.
    Wegen Rechnung muss ich nachfragen und ich sitze in Österreich.
    DHCP passt, was ich mit dem Zugriff via telnet und putti eigentlich außer Zweifel stellen wollte.
    Dass der Hersteller natürlich keinen Support für Eingriffe über diesen Weg leisten kann, ist mir wohl bewusst - würde ich auch nicht tun...
    Mein Problem ist, dass ich gerne die Daten von den Festplatten abziehen würde (für meinen Bruder), aber natürlich ein wenig anstehe, wenn ich eine der SATA Platten an mein Win OS hänge (teste gerade entsprechende Tools - viel Schrott dabei!).
    über 192.168.0.19 (priv. VLan - IP scheint im Router mit der MAC Adresse des NAS Devices auf), bekomme ich lediglich ein "Die Seite kann nicht angezeigt werden".
    Ich würde ja keine Komplettlösung benötigen, sondern lediglich einen Denkanstoß...
    Das mit dem Reset Schalter ist mir schon bewusst (eine Minute gedrückt halten sollte doch wohl reichen - nicht?)
    Für Tipps und Denkanstöße, wäre ich sehr dankbar..!

    Liebe Grüße,
    Tschortsch
    Hallo,

    gut, Österreich, da wäre dann ohnehin ausschließlich der Händler in der Pflicht. Direkte RMA Aufträge über Fantec sind leider nur innerhalb Deutschlands möglich.

    Gut, wenn die Datensicherung Priorität hat, sollte das B2 erst mal Nebensache sein.

    Es gibt da mittels Fedora eine Möglichkeit, die Platte(n) zu mounten, insofern sie als Raid1 im B2 eingestellt waren - in dem Fall jedoch bitte unbedingt weitere "Experimente" an den Platten unter Windows & Co einstellen (unter Windows kannst Du auf die Linux Partitionen eh nicht zugreifen) und Du benötigst die Zugangsdaten potenziell eingerichteter Nutzer.

    Du nimmst einfach eine der beiden Platten, baust diese in ein normales USB Gehäuse ein, startest die Fedora Live CD oder USB Stick Installation und schließt die Platte dann an den Rechner an (welche der beiden Du nimmst, ist dabei unerheblich - ist ja Raid 1), Du solltest die zweite Platte jedoch bitte unbedingt solange untouched belassen, bis Du die Daten gesichert hast. Sollte nämlich während des Sicherns etwas schief gehen, kannst Du es mit der zweiten Platte versuchen. Zusätzlich benötigst Du natürlich parallel einen dritten Datenträger, um unter Fedora die Daten zu transferieren.

    Was genau unter Fedora zutun ist, kannst Du hier How-To: Datenrettung von einer MR-35DRN RAID1 Festplatte in JayTee's TUT nachlesen. Es bezieht sich auf ein anderes Gerät, das aber ist Nebensache, es geht hier generell darum, wie man Raid 1 Platten sichern kann. Doch Achtung! Auch wenn die Schritte nahezu identisch sind, keine Panik, wenn der eine oder andere Schritt nicht klappt. So haben wir hier z.B. festgestellt, dass die B2 Platten nicht mehr zwangsläufig degraded werden müssen.

    Es empfiehlt sich auch unbedingt die Fedora Version 15 zu nehmen, wir haben festgestellt, dass es ab Fedora 18 schwer bis unmöglich wird, die Platten neu zu mounten. Es gibt noch diverse Quellen im Netz (leider nicht mehr auf der Fedora Project Page), wo man die Fedora 15 Version beziehen kann.

    Solltest Du da Wissenstechnisch aber an Deine Grenzen stoßen oder Dir das Ganze zu heiß sein, rate ich dringend von weiteren Experimenten ab, wenn die darauf befindlichen Daten wichtig sind. Dann mal bitte eine kurze Info an mich per PN/Konversation - gegen eine kleine Spende können wir auch hier (nicht Fantec. siehe Signatur/Über mich Seite im Profil) eine Datensicherung versuchen - natürlich unverbindlich und ohne jegliche Gewähr - ich denke was Datenrettungsfirmen für einen Kurs pro MB nehmen, dürfte bekannt sein ;) und selbst die übernehmen keinerlei Risiko oder Gewähr! Wir verfügen hier aber dafür über ein paar Optionen mehr, so z.B. technischen Mittel, die Platten auch Hardwareseitig auszulesen und zu sichern vermögen, OHNE unnötigen Zugriff auf die Platten zu vollziehen.

    Ach ja und sollten die Platten nicht im Raid1, sondern in einem anderen Modus gefahren worden sein, sind sämtliche Tipps hinfällig und es wird schwer, die Daten OHNE ein funktionierendes B2 auszulesen. Es ist ausschließlich bei Raid1 möglich, Daten "fremd" auszulesen. Davon ab bieten die anderen Modis des B2 ohnehin absolut null Sicherheit.

    Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „paddylein“ ()

    Hallo,

    dann mal viel Glück und beim nächsten mal einfach direkt auf den Punkt kommen, dass die Datensicherung Priorität hat :D . Für mich lass sich das nämlich erst mal so, als wolltest Du das B2 als Gerät einfach nur wieder zum laufen kriegen. Hier aber sind ja offensichtlich erst mal die Daten wichtiger.

    Grüße
    Hallo,
    Danke nochmal!!! - Daten sind nun auf einer externen USB Platte gesichert.
    @paddylein: "...als wolltest Du das B2 als Gerät einfach nur wieder zum laufen kriegen" - natürlich war das mein erster Ansatz, aber das "Kasterl" ist ersetzbar, wo hingegen die Daten unique sind und Datenrettung zu PRIO 1 avanciert ist, weil unterstützte Zugriffsvarianten (UNC/HTTP) nicht mehr gangbar waren.
    Der Verkauf (Support - Österreich) wäre auch dem Notfall Plan - "Datenrettung" - blank gegenüber gestanden, was mich umso glücklicher macht, in diesem Forum den entsprechenden Support für den "Notfall Plan" gefunden zu haben.
    Ich bedanke mich recht herzlich, und empfinde diesen Hilferuf als hinreichend aufgelöst.
    Alles liebe an die Community,
    Tschortsch
    Hallo,

    Was die b2 betrifft, bin ich inzwischen auch auf einen grünen Zweig gekommen:
    Bei dem Zugriff via Telnet auf Port 80 musste ich feststellen, das die NAS Box nicht auf diesen Port hört - schwer dann auf ipadresse zuzugreifen.
    Webserver Down? - Ja, wie sich später herausgestellt hat.
    ++entfernt++
    Seither geht die fedora Oberfläche wieder via 192.168.0.19 auf.
    Zumindest habe ich mein "Linux" wieder aufgefrischt - ist eh eine Schande, wie MS Powershell solche Skills verschrumpeln lässt.
    THX paddylein!
    Grüße,
    Tschortsch

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „paddylein“ ()

    Hallo,

    dass Du dem B2 wieder Leben einhauchen konntest, freut mich, doch noch mal: Der Zugang via Telnet und Co. ist offiziell unsupported, da man da auch eine Menge Fehler machen kann, können wir auch entsprechende Anleitungen hier, im offiziellen Support Forum leider nicht zulassen.

    Da das Problem aber nun von Deiner Seite her wohl gänzlich erledigt ist, mache ich dann hier mal dicht.

    Grüße

    CL-35B2 - Raid 1

    Hallo,

    Schon wieder ich. Nach einer Datenrettungsaktion, der NAS Raid 1 Member Disk, eines CL-352B, mittels einer fedora 15 auf meinen Rechner, ist das NAS Raid im Status "clean, degraded".
    So stellt sich das im Festlatten Dienstprogramm dar:
    /dev/md3:
    Version : 1.2
    Creation Time : Tue Jul 10 17:24:59 2012
    Raid Level : raid1
    Array Size : 1952988728 (1862.52 GiB 1999.86 GB)
    Used Dev Size : 1952988728 (1862.52 GiB 1999.86 GB)
    Raid Devices : 2
    Total Devices : 1
    Persistence : Superblock is persistent

    Update Time : Thu Jul 17 22:13:48 2014
    State : clean, degraded
    Active Devices : 1
    Working Devices : 1
    Failed Devices : 0
    Spare Devices : 0

    Name : myfantec:3 (local to host myfantec)
    UUID : c9918978:7589c367:e1232411:f07dd0b7
    Events : 167540

    Number Major Minor RaidDevice State
    0 8 17 0 active sync /dev/sdb1
    1 0 0 1 removed

    Sichtlich waren die Partitionen der Raid Disken mit ext2 erstellt und ich dachte mir, formatierst du die Platte, die du zum Datensichern verwendest hast, und startest das System neu - wird schon synchronisieren.
    Nix...
    ...drückst du am /dev/md3 auf "Wiederherstellen"
    Nix...
    Also entfernte ich auch alle Partitionen und habe so versucht, dem Raid vorzugaukeln, dass die einst entzogene Raid Disk (welche als removed angezeigt wird), der baugleiche Ersatz für ein "kläglich verstorbenes" Raid Mitglied wäre.
    ...System Reboot, "Wiederherstellen" drücken:
    ..Nix...
    System Log:
    Jul 17 21:02:45 myfantec smartd[1445]: System clock time adjusted to the past. Resetting next wakeup time.
    Das ist es wohl nicht - sonst aber auch nichts verdächtiges.
    Ich habe jetzt also ein Raid /dev/md3, das in dem beschriebenen Zustand ist und eine unpartitionierte, baugleiche Platte, die gerne dazu gehören würde.
    Im übrigen habe ich über den empfohlenen Zwischenschritt "FANTEC_CL-35B2_Firmware_20121220" die Firmware auf folgenden Stand gehoben:
    Firmware-Version20131121
    Kernel-VersionLinux myfantec 2.6.31.14-fast-20110801-fan #41 SMP Fri Oct 14 10:05:59 CST 2011 armv6l

    Habt ihr möglicherweise einen Tipp?
    Liebe Grüße,
    Tschortsch

    xxxxxxxxxxxxxxxxxxxxxxxxxxx
    Sorry - würde die Anfrage gerne löschen / lassen...
    Ein Anfall von Intuition hat mich auch die Idee gebracht, die "frische Platte" ins md3 Raid1 zu ziehen und dann auf "Wiederherstellen" zu drücken.
    Seit dem:
    [>....................] recovery = 0.0% (2432/1952988728) finish=13296.4min speed=2432K/sec
    /dev/md3:
    Version : 1.2
    Creation Time : Tue Jul 10 17:24:59 2012
    Raid Level : raid1
    Array Size : 1952988728 (1862.52 GiB 1999.86 GB)
    Used Dev Size : 1952988728 (1862.52 GiB 1999.86 GB)
    Raid Devices : 2
    Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Thu Jul 17 22:25:10 2014
    State : clean, degraded, recovering
    Active Devices : 1
    Working Devices : 2
    Failed Devices : 0
    Spare Devices : 1

    Rebuild Status : 0% complete

    Name : myfantec:3 (local to host myfantec)
    UUID : c9918978:7589c367:e1232411:f07dd0b7
    Events : 168131

    Number Major Minor RaidDevice State
    0 8 17 0 active sync /dev/sdb1
    2 8 1 1 spare rebuilding /dev/sda1

    ...blöd - einige Abende mit Herumgemurkse vertan und dann braucht man nur eine schriftliche Frage stellen, um sich selbst helfen zu können.
    Naja...
    Grüße!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „tschortsch“ ()