Probleme beim Abspielen von AVI Files über UPNP

    Probleme beim Abspielen von AVI Files über UPNP

    Hallo,

    ich habe kürzlich ein Firmware-Update meines 3DS4600 auf die Version r11498 durchgeführt. Seit dem habe ich Probleme, AVI Dateien von meinem Mediaserver (Synology) auf die 3DS4600 über UPNP zu streamen. Die Dateien werden zwar grundsätzlich korrekt abgespielt, konkret funktioniert das Vorwärts- bzw. Rückwartsspringen mit den Pfeiltasten aber nicht mehr bzw. nur fehlerhaft (UI zeigt an, dass z.B. 3 Minuten nach vorne gesprungen wird, in der Infobar wird der Sprung auch angezeigt, aber der Film springt nicht).

    Fast-Forward funktioniert grundsätzlich, allerdings mit unstetem Ergebnis (mal spielt die Datei von der Stelle, an die sie gespult wurde, mal "hüpft" er an einen anderen Punkt). Die selbe Datei von z.B. einem USB Stick abgespielt bereitet keinerlei Probleme weder mit Sprung noch mit FF/FR. Mit Dateien in MKV oder MP4 Containern funktioniert das vorwärts/rückwarts spulen auch einwandfrei, es betrifft scheinbar nur AVI Container. Es findet seitens Mediaserver kein Transcoding statt.

    Vor dem Firmware-Update funktionierte alles so, wie es sollte. Leider hab ich vergessen mir zu notieren, welche FW-Version auf dem Fantec vorher (also im Auslieferungszustand) drauf war.

    Was habe ich bis jetzt versucht:

    - Anderer UPNP Mediaserver --> gleiches Ergebnis
    - Gleiches File von anderem Medium (USB) --> Einwandfrei
    - Downgrade auf r11334 --> gleiches Ergebnis
    - Downgrade auf r9757 --> FW wird installiert, Fantec bootet aber nicht (bleibt im Fantec Bootscreen hängen)
    - Downgrade auf r6921 --> FW wird installiert, Fantec bootet aber nicht (bleibt im Fantec Bootscreen hängen)

    Ich möchte jetzt ungern alle meine AVI Files in ein anderes Format konvertieren. Ist ein solches Problem bekannt? Gibt es funktionierende Workarounds, die nicht "anderes Medium benutzen" oder "konvertieren der Dateien" heissen?

    Jayjay
    @paddylein: In den AVIs steckt ausnahmslos XViD. Wie gesagt, vor dem Firmware-Update hat alles anstandslos funktioniert.

    @Wolfman: Von einem Sambashare werden die Files anstandlos abgespielt. Der Mediaserver (über UPNP) bietet allerdings super Möglichkeiten, die Inhalte zu organisieren - daher ist für mich die Wiedergabe über Sambashare nur eine Notlösung, die ich eigentlich nicht nutzen möchte.
    Hallo,

    jayjay1896 schrieb:

    @paddylein: In den AVIs steckt ausnahmslos XViD. Wie gesagt, vor dem Firmware-Update hat alles anstandslos funktioniert.


    Genau deswegen frage ich, denn seid dem letzten Update wurde der Support für DIVX eingestellt - ob XVID mit dazu zählt, dessen bin ich mir jetzt nicht im Klaren, das kann Dir aber morgen Lars beantworten.

    jayjay1896 schrieb:

    @Wolfman: Von einem Sambashare werden die Files anstandlos abgespielt. Der Mediaserver (über UPNP) bietet allerdings super Möglichkeiten, die Inhalte zu organisieren - daher ist für mich die Wiedergabe über Sambashare nur eine Notlösung, die ich eigentlich nicht nutzen möchte.


    Samba hat aber weniger Restriktionen, als UPnP, um nicht zu sagen gar keine und darauf wollte Wolfman hinaus. Wenn möglich, immer Sambashares nutzen, ist immer der beste Weg, was unterstützte Formate angeht. Ist leider oft ein leidiges Thema mit UPnP/DLNA.

    Aber wie gesagt, warte bitte mal morgen Lars's Feedback ab. Nicht, dass wir hier wie wild rum spekulieren und die Lösung liegt förmlich auf der Hand ;) .

    Grüße
    Hallo,

    paddylein schrieb:

    Samba hat aber weniger Restriktionen, als UPnP, um nicht zu sagen gar keine und darauf wollte Wolfman hinaus. Wenn möglich, immer Sambashares nutzen, ist immer der beste Weg, was unterstützte Formate angeht. Ist leider oft ein leidiges Thema mit UPnP/DLNA.


    Hm. Das möchte ich so nicht stehenlassen ;) Sowohl mein letzter Player (eine PS3) als auch der Fantec vor dem Firmware-Upgrade hatten mit UPNP/DLNA keinerlei Probleme, solange auf der Quelle kein Transcoding der Inhalte stattgefunden hat. Und eigentlich sollte der Render-Engine ja egal sein, von welcher Quelle die Daten kommen.

    Vernünftiger UPNP-Support war bei mir ein hartes Kriterium für den Kauf eines Player. Und war ja nach dem Kauf auch gegeben. Scheinbar seit r11334 (da ist wohl DIVX Support noch drin?) gibt es Probleme mit UPNP und AVI-Containern. Dabei kann man beobachten, desto größer das File und desto länger das Video, desto größer die Probleme.

    Ich würde gerne ein Downgrade der FW machen, leider klappt das nicht so ganz... Nach dem aufspielen der Firmware r9757 oder r6921 (Forced Update Methode) bootet die Fantec leider nicht mehr. Die Versionen r11334 und r11498 lassen sich problemlos aufspielen, haben aber o.g. Probleme. Hat da vielleicht jemand einen Tipp für mich?

    Gruß
    Jayjay
    Hallo,

    jayjay1896 schrieb:

    Hm. Das möchte ich so nicht stehenlassen


    das mag sein, dass Du das so nicht stehen lassen möchtest und es ist natürlich super, dass Du bisher keine Probleme hattest und Dir der Player in der Hinsicht zusagte, es ist aber Fakt und auch kein Geheimnis, dass UPnP/DLNA teils extremen Restriktionen unterliet. Die Gründe dafür liegen in den DLNA Richtlinien und das Netz ist voll dazu ;) .

    jayjay1896 schrieb:

    Ich würde gerne ein Downgrade der FW machen, leider klappt das nicht so ganz... Nach dem aufspielen der Firmware r9757 oder r6921 (Forced Update Methode) bootet die Fantec leider nicht mehr. Die Versionen r11334 und r11498 lassen sich problemlos aufspielen, haben aber o.g. Probleme. Hat da vielleicht jemand einen Tipp für mich?


    Hast Du mal andere USB Sticks versucht? Normal sollte ein Downgrade auf die aller erste FW ohne Probleme klappen.

    Grüße