System blocked, need help!

    System blocked, need help!

    Hi
    I have a Fantec TV-FHDS that was working great ill now.
    Not it's blocked, it only shows the Fantec black screen and that's it.
    The only way to stop it is to unplug it.
    After reconnecting it's turned off. If I switch it on it stays the same situation blocked on the Fantec black screen.

    I wish I kept the receipt but I did not!

    So if anyone can help, please do so.

    Alex
    Hello,

    that sounds not good.

    How did you stream? By USB or NAS? Disconnect all of them. Only TV should be connected. Then test it again.

    Which Firmware is installed?

    You only can try to install the Firmware for new. If it doesn't works again it seems the FHDS is damaged.

    regards
    Mostly I used the USB, I have a 3T HD connected to the device.
    Unfortunately I can not check the firmware version as the TV screen shows the FANTEC written with white on a black screen.
    I wish there was a way to hard reset it.
    I tried it without any peripherals and it's still the same, then I tried only with the TV connected and still the same.

    It was a good device as long as it worked :(

    Thank you anyhow,
    Alex
    Hello,

    no, there is no way to reset the FHDS.

    You should anyway install this Firmware, because the Software in the Flash Memory can be damaged.

    It is no Problem to install the Firmware for a second or a third time. You cannot destroy the FHDS with it.

    By the way, original does not mean official, it means the first one. There were many Firmware updates after the orginal with new bootloader, but they all are official Versions.

    regards
    Hi

    This sounds great, but how can I do it? When I plug in the device to the 220V the front led is red, I connect the TV (or even without it) and then if I press either on the front button or on the power from remote control, the front led turns blue, the TV screen shows a black screen with Fantec written with White. And it stay there no matter what other button on the remote control I press. I can not shut it down by pressing either the power from the front or the power button from the RC.

    So in this case how can I install the upgrade?

    Thank you anyhow for the very fast replies!

    Alex
    Hello,

    if i read it correctly, you have disconnect the power at first, then you have reconnected it and after that you have pressed the power button, but that is not correct.

    Disconnect the power, then connect the usb stick with the Firmware.img (copied to the root) in one of the USB Hosts and now press the power button and hold it down, simultaneous reconnect the power. Hold down the Power button for about 10 seconds after reconnecting the power. The Update procedure should start now automaticly.

    regards