Problem with Fantec MM-FHDL

    Problem with Fantec MM-FHDL

    Hello,

    I have a Fantec MM-FHDL, it always worded nice.

    Yesterday evening I disconnected it from the TV (HDMI connection) to connect it to my laptop.
    That worked fine.

    After some work done I connected the disk back to the TV but nothing happend, it can't connect no more.
    I tried to connect it back to my laptop, nothing here, no connection.

    Without any cable connected the small display on the disk works fine, I can browse trough the menu with the remote control.
    But I cant get it connected to my TV or laptop.

    After some hours of trying, I got a connection on my TV. I thought everything was back OK.

    This morning I tested but again no connection on the TV!!!!

    What can be wrong and what can I do???

    Can anyone help me please.

    Thanks
    PietVB
    Thanks for the fast reply.

    I will try another cable this afternoon.


    But it wont connect to my laptop either, with a USB cable!!!!!!

    When it is connect with the USB cable, the fantec logo comes on the small display and nothing happens, it wont show on my laptop!!!!

    Greetz