Internal hard disk not detecting

    Hello,

    we need more informations please!

    At first tell us the complete Details of the HDD (manufacturer, type, size) please.

    Do yu have installed/formated the HDD only about the 3DFHDL Menue if you have bought it for yourself? It is important to install it only about the 3DFHDL Menue. Formatting or partitioning on a computer is not allowed and can make any trouble like this.

    regards

    Internal hard disk not detecting

    Details of the Hard disk is mentioned below>
    Western Digital WD Caviar Green 3TB SATA III 64MB Cache

    3.5" Desktop Internal Hard Drive..... well something that was really funny was when i downgraded the firmware it was perfect once again........
    Well i did format it using my PC... not from the 3DFHDL MENU..... do you think that this could be the Reason? .....
    Hello,

    yes, i think it is the reason by 90% because the 3DFHDL is creating two partions on the hard disk. The first is the bigger Partition for your Media Content. The second Partition is a little swap Partition you cannot see on the 3DFHDL. This partition is recommened for many internal functions of the 3DFHDL. if you install the hdd on a pc at first, the 3DFHDL cannot install the HDD correctly over the Menue after it. Some User's have problems from the first second and other Users' like you will get the problems at least if the firmware was updated.

    What you have to do now:

    Please backup your content on the internal HDD at first.

    Then you have to clean the HDD! Delete all partitions over the PC (you can make it in the USB Mode or install the HDD directly in your PC) with programs like the Windows Volume/Disk Management. Note: only delete the partitions, not more!!!

    Do not create any new partitions or format there anything in PC Mode.

    If you have deleted all partitions you have to reinstall the HDD in the 3DFHDL.

    If you have done it in USB Mode, you have to use the safely remove hardware function for usb mass storage devices at first, then you can disconnect the USB cable! This is really Important!

    Then follow the install instructions in the manual from the 3DFHDL! Normaly the 3DFHDL should show you on the 3DFHDL TV Menu the Install Window. If you have installed the HDD you can make the Firmware Update. If the 3DFHDL works after the update and the 3DFHDL shows you the correctly installed HDD you can copy your content backup back on the internal HDD.

    That's it :thumbup: .

    regards

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „paddylein“ ()

    I just bought the 3DFHDL and installed a brand new hard disk (right out of the box) of the type:
    Brand:
    Serie: WD 2TB 3.5" SATA-600 IntelliPower 64MB
    Model:
    Art. nr. : WD20EARX
    Interfaces:
    1 x Serial ATA-600 - 7-pens seriële ATA
    Conformiteitsnormen:
    S.M.A.R.T.
    Functions:
    IntelliSeek, IntelliPower, NoTouch ramp-load technologie, GreenPower technologie, Advanced Format-technologie
    Interfacetype:
    Serial ATA-600
    Capacities:
    2 TB
    Size buffer:
    64 MB

    I didn't use my Seagate 7200 drive as mentioned in this link: Festplatte Seagate Barracuda 7200.11 ST31500341AS, 1.5TB
    But bought the suggested WD green.

    After installing it I connected the box to my TV set and went through the settings and formatted the HDD.
    Everything worked well, the disk icon went on about 12 seconds after the initial showing of the main interface.
    I was able to access it on my PC via Samba, and copy my movies to it.

    The box came with Firmware 3DFHDL v10.1.11 r7663 - 02.03.2012
    Then I updated the firmware to: Firmware_FANTEC_3DFHDL_20120817-v10.1.11_r9239

    After a reboot the box wasn't showing the HDD any more. All the other functions were oke.
    Tried several reboots and power offs but the HDD still wasn't showing (I can hear The HDD starts spinning and running on reboot).
    Then I left the box on and suddenly after about ten minutes the HDD icon came on and the disk was accessible.
    But after I switched the box to standby the HDD was gone again.
    So what happens is that when I get lucky the HDD will come up after a few minutes (not a constant time, then shorter, then longer).

    I decided to follow the instructions of the above post, removed all the partitions and was able to format it again (in NTFS mode).
    But the problem remains the same.
    Then I removed the partitions again and formatted it this time as EXT3 to see if this solved the problem, but it didn't.

    Basically: The box starts oke and drive spins up, but doesn't show, and I can't access it. When I try to format in this situation it says: no disk. When I attach the box via USB3 at my PC the drive is oke.
    Sometimes (not always) it comes up after several minutes. Problem exists with both the Android as the none Android firmware.

    At the moment I flashed back to the old firmware (Firmware_FANTEC_3DFHDL_20120302-v10.1.11_r7663) and the drive immediately came back on (several seconds after the main interface appears) and works oke.

    This HDD is from the "same" series as the one mentioned in the initial post, so could it be a problem with one of the functions of this HDD?

    As you can imagine I really want to upgrade to the latest firmware, and the ones to come, so if anyone can help me with this problem it would be much appreciated.



    EDIT:

    Tested the box with the latest firmware and my Seagate Barracuda 7200.11 1500 Gb. The above problem doesn't excist, disk formats and comes up as normal.

    Tested the box with the latest firmware and a WD800J 80 Gb. The above problem doesn't excist, disk formats and comes up as normal.

    Mounted the WD20EARX green disk after a format in the box on my PC and tested it with the WD Align software. It shows that the partition created by the box isn't alligned meening the Advanced format technology from the disk will not work in the box, and according to WD will work at at slow speed.

    Can it have something to do with the Linux Kernel version used on the box, as I understand only the latest Linux distributions know how to handle the Advanced format technology, or could it have something to do with the HDD's Intellipower function?

    Is there a way to telnet into the box and try to see what's going on, or play with the mount functions?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „rudrood“ () aus folgendem Grund: New tests

    Hello rudrood,

    1. After you cleared the HDD with deleting all partitions, do you format the HDD on PC or within the 3DFHDL ??
    It's very important to let it do the 3DFHDL. It will make a swap-partition and so on ...

    2. If you start/reboot the device first time after filling it with your backed up data, you have to wait for the 3DFHDL to end "scanning & actualizing the bibliothek". It could be some minutes depending on how much files there are on HDD.

    3. How do you update(d) the new firmware r9239 (within the setup-menu of the 3DFHDL or with "Forced Update Method")?
    It's guessed to do it with the forced update method.

    Sorry for asking you this so explicit, but we have to know it exactly for diagnostic - thank you for appreciation. :thumbup:
    Greetings, TM
    FANTEC R2750 (2 TB) + 3DFHDL (2 TB) + CL-35B1 (1 TB)

    DENON AVR 1910 (HD 7.1) . . . LG 37" LV5590 LED-TV


    Hi thanks for your answer, I just now edited the previous post with some new test results.

    To answer your questions:

    1. After I cleared the partitions on the PC I formated it in the 3DFHDL (I used this same methode with the Seagate Barracuda 7200 that works oke).

    2. I'm aware of the scanning process, but the problems also excists with no data, or just one movie, and I waited several minutes.

    3. I updated the new firmware within the setup menu of the 3DFHDL. Also with the latest tests with the other disk I used this methode.

    Thanks again for your reply, I hope these results will help me solve the problem.
    Back again,

    Forced method firmware update went smoothly, with the Firmware_FANTEC_3DFHDL_20120817-v10.1.11_r9239 (no Android version).
    After initial bootup the HDD wasn't available (in format menu it says: no device). Then I put the box in standby and turned it on again.
    No HDD available, after several minutes it suddenly was there and I was able to format it in NTFS mode.
    HDD was accecible over the network and I was able to put some files on it.
    Then I put the box in standby again and turned it on, but now the HDD was gone again. Waited several minutes, but no luck.
    Tryed it again and left the box on for over 10 minutes now, but still no HDD.

    If this helps:
    During turning the box on I hear the HDD spin up, then it "calmes down" but keeps turning. When the main interface comes up I can hear the HDD make some extra noises for a second, but nothing happens.

    Regards!
    Hello,

    a little bit strange this problem. Normaly we have problems with Seagtate HDD's and their older firmwares but not the WD's and specialy not the 20EARX Models. 8o

    I cannot really understand the problem but i think it is the WD HDD for about 90%, because you have tested other HDD's and they works!!! So it cannont be a problem of the 3DFHDL normaly. Other User'S did not have any PRoblems with the 20EARX Models.

    reagards
    There's definitely something wrong with the updated firmware,
    all instructions mentioned above had been done..... The HDD is not been detected by the media player, lets say that its not very consistent,
    i need to reboot the player several times for it to detect ... but then again if i try to switch the player "OFF" and "ON" again ..theres no trace of the HDD once again... its super crazy!
    the strangest thing that i had experienced, i did not have any sort of problem with the previous firmware.......

    hard disk type (Western Digital WD Caviar Green 3TB SATA III 64MB Cache)
    Hello,

    this problem seems to be very strange. Please wait for an answer from the official Fantec Support on Monday! I will close this thread for a while because i think no one else could give you an plausible Answer for it, only the official Support. If there is any update from your site, give me a little feedback via pm and i open the Thread. :thumbup:

    regards
    Hi Lars,

    You may be right, but you were lucky you had a propper functioning 3DFHDL.


    To make a long story short, this is what happened to me till now:
    I received a new HDD from Western Digital and the problem was exact the same...
    I contacted my local reseller and they agread to send me a new Fantec 3DFHDL that I received today.
    I installed the latest firmware and the HDD and the problem seems to have been solved...
    I put the box into standby and took of the power several times to test, but the HDD is present all the time.
    So it seems that the problem wasn't the HDD but the 3DFHDL itself (in combination with the latest firmware).

    Some things I noticed:

    Now when I rotate the box the display also rotates, this didn't work with the first box.

    When I mount the disk via USB at my PC there is only one file and two folders there, with the first box there were several files there all the time.

    The serial nr. of the box is very different, the first one started with 1111215.... and now it starts with 151111.........

    @modjoxtrem:

    I think it's fair to conclude that after all this testing and getting a new HDD that didn't seemed to be the problem at the first place, it would be wise for you to contact Fantec and get your box repaired or replaced.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „rudrood“ ()

    Hi,

    you can trust me, i have seen so much 3DFHDL and no one got this problem (testing with only one device is way to less for safety reasons). ;)

    Conclusion: we don't know what was wrong at your place, if it's neccessary modjo can contact his merchant for a RMA and everything will go its way, but this can only be tested here on site. :thumbup:

    Best regards,
    Lars