P3700 Web don't show anything out of the box

    P3700 Web don't show anything out of the box

    Hi all,

    I've just received my brand new P3700, just opened it, install the 1TB WD HDD andplug it with network, hdmi and power then... got nothing on TV...

    Got only the red ring goes blue and... nothing ;(

    I tried so many things... restore bootlader, restore firmware with the 20s power button trick and... still nothing the keys don't show anything tryed with 4 USB sticks...

    I tried with another HDD (seagate this time still 1TB) but nothing @ all...

    I can see the hard drive when I plug in a my computer with USB cable nothing else...

    Please help !

    There is a key on your remote "tv.sys" it is very possible your player is set to fullhd 1080p resolution and i presume the tv cannot show image with such resolution...also double check hdmi cable insertion inside the player and inside the tv...try also scart connection to tv... press multiple times tv.sys key until you find the proper format supported by your tv..when led is blue player is started....when led is red player is in standby.

    LED LG 47LE5300 47 inch...Fantec p3700 2TB...Bang & Olufsen custom build sound system...Patriot TS-639 Pro Turbo NAS 4TB
    Thanks you for your both answers,

    My TV is 1080p capable but that's not the problem, I tried on another TV 1080p ready and and the problem is the same.

    Tried with three HDMI cables with no success

    I also tried with a scart cable but no results too...

    The led goes red when I plug power cord and blue when I push the power button on the box or on the remote controller.

    the Tv sys. button doesn't change anything...

    And as a clue (I guess) I got nothing on the LCD of the player.

    And the blue usb3 cable is disconnected :)

    any suggestion ?

    Thanks by advance again