Mount S3600 Festplatte mit LAN

    Mount S3600 Festplatte mit LAN

    Hi, I have a problem with my S3600.

    Since 3 days I can't access my usb disk using network.

    I have 3 Macs and 2 PCs, network is working (I can read files that are on my Mac using S3600)

    I used to click on "Fantec" name in my sidebar and mount USB1 on the desktop to access disk and transfer files but it is not possible now, I can ping S3600, I can even use the web remote but I can't mount the remote disk. Most times the S3600 doesn't announce itself on the network and I have no link in the sidebar, but I can't connect even using smb://IP (or \\IP on Windows).

    I tried literally EVERYTHING (power cycle, beta firmware, disabling firewall) to no avail.

    Please help. I don't understand German but I try to translate this using google and attach below.




    Hallo, ich habe ein Problem mit meinem S3600.

    Seit 3 Tagen habe ich keinen Zugriff auf meinen USB-Festplatte mit Netzwerk.

    Ich habe 3 Macs und 2 PCs, Netzwerk funktioniert (ich kann Dateien lesen, die sind auf meinem Mac mit S3600)

    Früher habe ich auf "Fantec" Namen in meiner Sidebar klicken und montieren USB1 auf dem Desktop auf die Festplatte zugreifen und Dateien übertragen, aber es ist nicht möglich jetzt, ich kann S3600 Ping, ich kann sogar mit dem Web-Fernbedienung, aber ich kann nicht gemountet Remote-Platte. Die meiste Zeit der S3600 nicht angekündigt sich im Netzwerk und ich habe keinen Link in der Sidebar, aber ich kann nicht in Verbindung zu treten sogar mit smb: / / IP (oder \ \ IP unter Windows).

    Ich versuchte wirklich alles (wieder einschalten, Beta-Firmware, deaktivieren Firewall) ohne Erfolg.

    Bitte helfen Sie. Ich verstehe nicht deutsch, sondern ich versuche, diese mit Google Translate und fügen Sie unten.



    i think it's a problem in your network but i can't tell you what you can do in this case because i don't know it.. ;) (check the Firewall, Antivirus Programms, etc.)

    For the S3600: Reinstall the Firmware r2213, Stop the NAS Mode and then reenable the NAS Mode, this is all you can do.

    For connecting to a SMB Share use \\IP

    Best regards,
    I don't know what the problem is but I am sure what it is not: my network :P
    My lan is a pretty well configured mixed environment with Macs and PCs constantly sharing files using SMB, FTP, AFP, SSH protocols.
    That said, I can use S3600 to play movies that are on any computer in the lan without any problem, but I can't see S3600 from computers.
    Strange, huh?
    I'll try to reapply 2213 update tomorrow, I'll let you know.


    Edit: Just tried. Now I see "fantec" in sidebar but I have a "connection failed" message...

    Post was edited 1 time, last by “lucaspeed” ().

    I had and still have the same issues (network also with PCs, one MAC and another multimedia streamer from Xtreme, SMB works just great between all machines with one exemption: the S3600): the box "Fantec" is listed as being on the network but when I try to connect to it I get the same "connection failed" message. The update to 2213 did not help at all and Fantec's continues to claim it is not their box... Fortunately, the file transfer via ftp works (even if it is incredibly slow), so I am able to transfer files on the eSATA HDD connected to the Fantec box.

    Good luck to you.

    P.S. What is the Windows version you use? I use Windows 7 Ultimate or Home edition on all my PCs.
    I bought it through ebay directly in Germany from Bravotec, at the time it was impossible to find here in Italy.
    I'd like to send it back but it is costly and I know for sure it isn't an hardware problem, networking FROM S3600 is working fine. The only problem is with SAMBA and I hope it will be resolved in a future firmware revision. I can try to check smb.conf or rc scripts using telnet, too.
    At least there is a good reason to be a linux geek… :)

    FYI, I use Ubuntu and Windows 7 on PCs, and Mac OS X 10.6.7 Snow Leopard on Macs (my primary computers)

    P.S.: S3600 refuses connection even using FTP but if I am correct it depends on the disk being USB and not eSATA, right?

    Post was edited 1 time, last by “lucaspeed” ().

    The same for me: bought it from Germany from Technikdirekt. It will cost too much to send the box back and the problem does not seem to be HW related (hard to believe you are using a dedicated chip for SAMBA only)...
    If there is a way to fix this using telnet (reinstall or modify smb.conf or rc scripts etc), please post a solution so we can try it.
    I have identified the problem, and (partially) solved it.
    For some reason samba is starting with a very low priority, killing and restarting manually using telnet solved the problem.
    For users with the same problem, here's how to reestablish samba connection:

    open terminal (*nix) or cmd (Windows) and type:

    telnet IP_OF_YOUR_S3600 and press enter

    the login name is: root
    no password needed

    In the following examples # represents the prompt and should not be typed.

    do a:

    # ps and press enter

    You'll see a list of processes running on your S3600.
    Near the end of the list you'll notice 2 smbd and 1 nmbd processes
    The number starting the line where the process reside is its PID (process ID), we need to kill it, so please take note of these 3 number and kill them using:

    # kill and press enter
    # kill and press enter
    # kill and press enter

    check using

    # ps and press enter

    that processes smbd and nmdb are closed and type (caps are mandatory):

    # /sbin/package/samba/sbin/smbd -D and press enter
    # /sbin/package/samba/sbin/nmbd -D and press enter

    Now try to reconnect to S3600 as usual, you should be able to connect correctly.
    Use this as a temporary solution, it will last until you shut down S3600, I'm investigating ways to have samba started correctly in a definitive way.

    Regards, Luca

    Post was edited 1 time, last by “lucaspeed” ().

    tried the fix but I encountered two problems:
    - I do not see in the process list the 2 smbd processes to kill. They appear shortly after I power on the S3600 and 2 seconds later are gone.
    - after I kill the nnbd process and try to start the two processes, after I check again the list, I see again only the nmbd -D but no smbd process.

    Inside the /sbin/package/samba/sbin/ folder I see three files: nmbd, smbd and one smbpasswd

    Any more idea?

    Thank you.

    there are no problems at the moment with samba.
    The only thing you have to do, after plug in a USB-Drive, is to switch NAS off and on to be recognized.
    If it doesnt work try to connect the S3600 directly to your PC and test it with fixed IPs.

    Regards JT
    Hi JT,

    Is this a joke? What do you mean "There are no problems with SAMBA"? When you read this forum, you will see many people complaining about network access to S3600. Now you come with the idea that it shall work for USB drives. What about eSATA connection? If SAMBA is just fine, why it does not work for both USB and eSATA?

    I have tried all solutions:
    - USB or eSATA connection
    - DHCP allocated or fix IP address
    - the solution proposed by luca
    - upgrade from the original FW release to the latest one.

    The conclusion is one and only: there is something fishy with your SAMBA implementation.
    Sorry for my late reply, but the solution proposed by J.T. simply does not work, because switching NAS on and off simply restart nmbd daemon but not the smbd one.
    I am a little slow doing these tests as I don't have a lot of free time, but what I have understood is that smbd starts and after 30~60 seconds simply dies.
    The real problem with S3600 is that after that it is impossible to start it again even switching NAS on/off, so my solution works only if you manually kill smbd and nmbd soon after they start and subsequently launch them again using the commands in the post above.
    Unfortunately Venus linux is a very poor documented platform (at least for us normal humans) and I prefer not to make a mess in the filesystem.
    These so called "hints" to check a perfectly working network or use it with fixed IPs are useless, because I think people have tried them in first instance.
    What we need is someone at Fantec with a pair of spare hours to check for this issue prior to say that it doesn't exist…
    I think every single euro I gave to Fantec (with S3600 now and TV-FHDS last year) were good and properly functioning so I want a properly functioning device.

    Hoping to find a solution, regards

    Here is a picture from my PC


    took my 2 min to setup.
    I use the latest fw and the s3600 is connected directly to my pc with fixed IPs.
    hdd1 is the e-Sata HDD and usb1 is my USB-Stick.
    Both are running now over an hour and are still reachable even after reconnecting and without restarting the NAS-Mode.

    I dont know whats wrong on your side, maybe its the player maybe not.
    If its the player feel free to send it to us for a check.

    Kind regards JT
    Ok, I just tried your setup.

    Windows 7 PC directly connected to S3600.
    Trying to connect to \\ show a blank page (USB disk connected), clicking on FANTEC name in the sidebar asks for a username and password (leaving blank don't work).
    I tried switching NAS on/off and with DLNA active and not active.
    I tried switching lan cables (cat 5 - 5e - 6)

    Just to assure you that the problem is only with samba, connecting with telnet I can navigate the directory structure and the mounted filesystems and operate on files without any problem.

    I have Macs and Linux machines to make test with but with the same results…

    P.S.: as I am on r2213 firmware now, please can you post or give me a link to the original firmware, so I can test access again with it?

    Post was edited 1 time, last by “lucaspeed” ().

    J.T. wrote:

    Here is a picture from my PC…481cce5074c275ca594dd55c4

    took my 2 min to setup.
    I use the latest fw and the s3600 is connected directly to my pc with fixed IPs.
    hdd1 is the e-Sata HDD and usb1 is my USB-Stick.
    Both are running now over an hour and are still reachable even after reconnecting and without restarting the NAS-Mode.

    I dont know whats wrong on your side, maybe its the player maybe not.
    If its the player feel free to send it to us for a check.

    Kind regards JT

    The configuration you are presenting is not the normal one: computer(s) and S3600 are connected on a local LAN through a switch and a router (they are almost never connected through a normal cable). Anyhow, I tried the followings:
    - connect an USB HDD to the S3600
    - set a fixed IP adress for the S3600
    - set the NAS to off and back to on
    With all these, still there is no SAMBA process running on the S3600. It runs for few seconds after S3600 is powered on and after that it disappears from the list of active processes.

    If you would accept an RMA to be sent directely to Fantec, I could send my box to you for check/repair/replacement. Otherwise, I found it too risky and expensive to work through the seller.
    Please, someone can tell me why the network is good to do EVERYTHING but SAMBA?
    I am curious!

    Lars, JT, please, take a good look at the last image and tell me again "SAMBA is OK, it is YOUR NETWORK"...

    Post was edited 1 time, last by “lucaspeed” ().


    again I made a little test, took me 4 min ;)

    I took a Macbook from a collegue which is connected over WLan
    and the S3600 which is connected over Lan.
    This time 2 USB-Sticks and 1 HDD over e-Sata are connected to the S3600.

    Picture from the Webgui
    Bildschirmfoto 2011-05-05 um 09.42.19.png

    Picture from the telnet session
    Bildschirmfoto 2011-05-05 um 09.46.17.png

    Picture from the smb connection
    Bildschirmfoto 2011-05-05 um 09.47.04.png

    So everythig is running good :)

    Regards JT